Page fails to load, browser crashes [@JVM_NewInstance]

VERIFIED DUPLICATE of bug 154699

Status

--
critical
VERIFIED DUPLICATE of bug 154699
16 years ago
5 years ago

People

(Reporter: sarrica, Assigned: joe.chou)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072203

The URL www.printimage.org/indNews/43.html produce a crash every time I try to
load it.  This is under the Mac OS X 10.2 GM.

Reproducible: Always
Steps to Reproduce:
1.  Try to load www.printimage.org/indNews/43.html


Actual Results:  Mozilla quits unexpectedly and Mac OS X 10.2 reports same.

Expected Results:  The page should have loaded normally.

Comment 1

16 years ago
wfm using build 20020803 on Linux (trunk).

Reporter, are you using Java ? Do you still crash when desactivating Java ?
Reporter : 
PLease attach a MAC OS X crashlog !

Comment 3

16 years ago
This crashes my today's BRANCH_1_0 build on Mandrake 8.2 Linux when I have Java
ON. If I turn it OFF, the page loads OK.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Martin: 
Please add more informations if you confirm a bug.
JRE Version ?
possible Talkback ID ...
(Reporter)

Comment 5

16 years ago
Crash still occurs if Java is disabled on Mac OS X 10.2 GM.

Sorry, I'm a newbie.  How do I generate Mac OS X crash log and submit it?
Under OS X, you can enable CrashReporter to provide this data. See
[http://developer.apple.com/qa/qa2001/qa1057.html].
(Reporter)

Comment 7

16 years ago
Created attachment 93944 [details]
Mozilla crash log for Bug #160995
(Reporter)

Comment 8

16 years ago
Created attachment 93945 [details]
2nd crash log

Updated

16 years ago
Attachment #93944 - Attachment mime type: application/octet-stream → text/plain

Updated

16 years ago
Attachment #93945 - Attachment mime type: application/octet-stream → text/plain
So *that's* what a mid-air collision looks like ...

WFM on Win2K SP3, 2002080208 with JRE 1.4, but Java console shows the following
each time the applet loops:

java.lang.NullPointerException: string is null

	at sun.java2d.SunGraphics2D.drawString(SunGraphics2D.java:2564)

	at FaetonWriter.paint(FaetonWriter.java:209)

	at FaetonWriter.update(FaetonWriter.java:219)

	at sun.awt.RepaintArea.paint(RepaintArea.java:172)

	at sun.awt.windows.WComponentPeer.handleEvent(WComponentPeer.java:260)

	at java.awt.Component.dispatchEventImpl(Component.java:3586)

	at java.awt.Container.dispatchEventImpl(Container.java:1437)

	at java.awt.Component.dispatchEvent(Component.java:3367)

	at java.awt.EventQueue.dispatchEvent(EventQueue.java:445)

	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:190)

	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:144)

	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)

	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:130)

	at java.awt.EventDispatchThread.run(EventDispatchThread.java:98)

This is a crash in teh Java plugin 
-> Oji
Assignee: attinasi → joe.chou
Component: Layout → OJI
QA Contact: petersen → pmac
(Reporter)

Comment 11

16 years ago
I thought I had disabled java under Preferences/Advanced... is there something
else I need to do to turn it off?

Comment 12

16 years ago
With Java(TM) Plug-in 1.3.1_02-b02 turned ON, the browser (branch10) crash on
Linux with
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: No such file or directory
Keywords: stackwanted
Martin: Your Java is not correct installed. You crash has nothing to so with
this bug

Steve : AFAIk You must simple disable it in the pref. As you can see the stack
it crashes in the JVM (JVM_NewInstance). 

Comment 14

16 years ago
Matthias: right, I've reinstalled new jre plugin and it WFM now.
(Reporter)

Comment 15

16 years ago
Matthias, I've checked several times now and the "enable JavaScript" setting is
unchecked.  If that is all that is required to disable the java plug-in, I am
confused as to how the java plug-in could still be crashing things.

Sorry if I am missing something obvious...
Javascript is not Java (only the name sounds similarly)

edit\preferences\advanced\[] Enable Java
Removing MRJPluginCarbon.plugin from the bundle will get this page displaying. 
Presumably Apple's plugin is taking over.

Updated summary to include crash location for easy searching.
Summary: Page fails to load, browser crashes → Page fails to load, browser crashes [@JVM_NewInstance]

Comment 18

16 years ago
Java plugin does not work on OS 10.2. dupe of 154699.

*** This bug has been marked as a duplicate of 154699 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Brian: even though this has a different stack?  I dunno, just pointing it out.
Bug 162206 has the same stack as this one.

Comment 20

16 years ago
Verified dup of bugzilla bug: 154699
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
Crash Signature: [@JVM_NewInstance]
You need to log in before you can comment on or make changes to this bug.