Closed Bug 1610165 Opened 3 years ago Closed 3 years ago

SVG images that fail to get inserted into the cache get stuck in a repaint loop

Categories

(Core :: Graphics: ImageLib, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Playing a bit with the cache params to investigate bug 1609672, I noticed via logging that we always repaint SVGs that fail to get inserted into the cache.

Fix seems trivial.

I was poking at the missing images bug by dropping cache sizes and such and
found that we always ended up repainting some SVGs over and over. This seems to
be the cause. When we fail to insert into the cache we still end up notifying
over and over (because we forget to say aWillCache=false), so we'd end up
repainting, and failing again, etc.

This is easy to see adding some logging to
nsDisplayBackgroundImage::PaintInternal.

Any ideas as to how to add a test for it?

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/206cec28723a
Failing to insert an SVG into the surface cache continuously repaints the image. r=tnikkel
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
You need to log in before you can comment on or make changes to this bug.