Closed Bug 1610202 Opened 3 years ago Closed 3 years ago

[Wayland] Full-screen video toggling after window switch makes a mess

Categories

(Core :: Widget: Gtk, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1615098

People

(Reporter: grayshade, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

  1. Open Firefox with some tabs
  2. Open a new Firefox window and load a YouTube video
  3. Make it full-screen and restore it (works)
  4. Switch to the first Firefox Window, then back (I'm on Gnome Shell)
  5. Make the video full-screen again

Actual results:

I'm not exactly sure, but the second window becomes unusable and needs to be closed.

This is a recent (last 1-2 weeks) regression, but might be older than the DMABUF change. I didn't try mozregression yet.

Attached image mess.png

It's not clear from the screenshot, but the non-full-screen window gets drawn over the video and cannot be interacted with. The YouTube seek bar is visible at the bottom, where used to be a panel. The mouse cursor doesn't get drawn over the window part.

This whole "window" stays on top of the other applications and I need to close it with Alt-F4.

Component: Graphics: Layers → Widget: Gtk

This happens even in a new profile (once I enable Wayland).

I tested this again. The problem still occurs, however after switching to another window then back, it works normally. So it got a little better.

Regressed by: 1605120
Has Regression Range: --- → yes

This seems to have gotten worse between the 26/28 Feb nightlies. Now it happens right from the start, not only in windows opened while the browser was running.

Closing as a duplicate of 1615098, since that one seems to have gained more traction.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1615098
You need to log in before you can comment on or make changes to this bug.