Closed Bug 1610397 Opened 2 years ago Closed 1 year ago

Double clicking multiple words in separate search box selects all text instead of the word being double clicked

Categories

(Firefox :: Search, defect, P3)

70 Branch
Unspecified
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 75
Tracking Status
firefox-esr68 --- unaffected
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified
firefox76 --- verified

People

(Reporter: yoasif, Unassigned)

References

(Regression)

Details

(Keywords: regression)

From: https://www.reddit.com/r/firefox/comments/erf08d/7201_i_can_no_longer_drag_links_from_the_address/ff3dg9i/

Steps to reproduce:

  1. Enable separate search box
  2. type two or more words in search box, like "example example"
  3. Double-click the first "example"

What happens:

Both words are selected.

Expected result:

Only the first word is selected.

21:33.97 INFO: No more inbound revisions, bisection finished.
21:33.97 INFO: Last good revision: 37fd68a3d10d0ec85350177152ab9af8425f0d3c
21:33.97 INFO: First bad revision: d57c700859fbd63684386e0bf063331460753bc4
21:33.97 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=37fd68a3d10d0ec85350177152ab9af8425f0d3c&tochange=d57c700859fbd63684386e0bf063331460753bc4

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1528614
Keywords: regression

Hey looks like your patch changed behaviour here, any ideas? Cheers

Flags: needinfo?(htwyford)

Note that this is linux-only and affects both the address bar and the search bar.

On Ubuntu 18.04.3 LTS I could reproduce the issue that it affects the search bar, as far as Firefox version 70.0. Therefore, will add the according flags.

Regarding the issue that it affects the address bar. I could still reproduce it even on Firefox version 55.0. Don't know when it first started though, or if this isn't expected from it?

(In reply to Mark Banner (:standard8) from comment #2)

Note that this is linux-only and affects both the address bar and the search bar.

Is this not the expected behaviour on Linux? Unlike on other platforms, on Linux browser.urlbar.clickSelectsAll is false, and browser.urlbar.doubleClickSelectsAll is true. Afaict, we didn't support doubleClickSelectsAll in the searchbar before bug 1528614 landed. Now that we support that pref in the search box, the actual behaviour described in comment 0 is expected: all the text in the search bar is selected when the input is double clicked.

Flags: needinfo?(htwyford)

I tried all the way back to 68ESR on Fedora (new profiles); all of them select the entire contents of the URLbar on single-click, and there are no numbers of clicks to select just a word.

The search box I have enabled in my nightly and works the same; single click selects all, no way to select a word

In 69 a single click in search puts the cursor in, 2 clicks selects a word, 3 clicks selects all.

"clickSelectsAll" has never been set on the urlbar, these mixed urlbar/searchbar reports are confusing, Bug 1528614 can't have affected the urlbar. Harry is correct that the urlbar behavior depends on the value of browser.urlbar.clickSelectsAll and now the search bar acts the same way.

(In reply to Randell Jesup [:jesup] (needinfo me) from comment #5)

I tried all the way back to 68ESR on Fedora (new profiles); all of them select the entire contents of the URLbar on single-click, and there are no numbers of clicks to select just a word.

That's totally unexpected, maybe Fedora is setting some prefs?
What's the value of browser.urlbar.clickSelectsAll and browser.urlbar.doubleClickSelectsAll on the profile where you can reproduce the problem?
Does the search bar behavior differ from the urlbar behavior?

Flags: needinfo?(rjesup)

The URLbar is the one that selects-all only, back to 68. The search bar used to do cursor/select-word/select-all, now it does cursor/select-all (like the URLbar).

browser.urlbar.clickSelectsAll: false
browser.urlbar.doublelickSelectsAll: true

This isn't surprising; the issue is that this now affects the search bar

Flags: needinfo?(rjesup)

The fact they work the same is expected imo, the proper order of things with the prefs set like that is cursor/select-all. So it all looks expected.
The sad thing is we lost select word. Also, with the prefs inverted (as they are on other platforms), on Windows (at least) I can double click to select word.
This may be another reason for which we should actually unify all the platforms to the Win/Mac behavior (bug 333714), if we'd solve the primary selection problem.
Worth discussing this, anyway.

(In reply to Marco Bonardo [:mak] from comment #8)

Worth discussing this, anyway.

Who do we need to discuss that with?

Flags: needinfo?(mak)
Priority: -- → P3

I meant discussing in the team, especially Verdi. The desired outcome is unclear, the clickSelectsAll (and double) thing just keeps having edge cases, now we lost one feature (select-word) when clickSelectsAll is defaulting to false.

Depends on: 333714
Flags: needinfo?(mak)

Per comment 10, NI to let you know this needs discussion/decisions/design

Flags: needinfo?(mverdi)

Thi should now be fixed along with bug 333714, as a consequence of unifying the urlbar behavior across platforms, the search bar behavior has been unified with the urlbar as well.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75
Flags: qe-verify+

I managed to reproduce the issue on Ubuntu 16.04 x64 using an older version of Nightly 2020-01-05.
I verified the fix using the same OS on latest Nightly 76.0a1 and beta 75.0b3. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(mverdi)
You need to log in before you can comment on or make changes to this bug.