Closed Bug 1610784 Opened 1 year ago Closed 8 months ago

Dropdown menus showing on wrong monitor

Categories

(Core :: Widget: Cocoa, defect, P2)

72 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1592416

People

(Reporter: wolfkarl, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

After updating to Mac OS Catalina, the following issue appeared when opening almost any kind of menu:

  • Opening the downloads menu
  • Textbox suggestions, dropdown menu in password fields
  • Folders in the bookmarks toolbar
  • Switching videos to full screen
  • Right-click context menu

This does NOT happen for the bookmarks menu and the main menu to the right.

Actual results:

These menus always open on the first workspace on the primary monitor (integrated Macbook display in my case) and are not properly scaled (too small).

When switching to a different workspace on the primary monitor, menus don't appear at all.

After restarting the browser, things sometimes work as expected for a couple of times, then stop working without any changes, e.g. just opening and closing the download menu breaks it.

Expected results:

Menus should open on the same monitor the Firefox window is on.

Component: Untriaged → Widget: Cocoa
OS: Unspecified → macOS
Product: Firefox → Core
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1592416

Sorry, realized this is about dropdown, not context menus. Possibly the same root cause though.

Blocks: catalina
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
See Also: → 1592416
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

The priority flag is not set for this bug.
:spohl, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(spohl.mozilla.bugs)
Flags: needinfo?(spohl.mozilla.bugs)
Priority: -- → P2

:haik, can this be closed as a duplicate of bug 1592416?

Severity: normal → S3
Flags: needinfo?(haftandilian)

(In reply to Stephen A Pohl [:spohl] from comment #4)

:haik, can this be closed as a duplicate of bug 1592416?

I think this is probably a duplicate of bug which we are close to having a fix for.

The report mentions different workspaces and multiple monitors which is a problem case being addressed on bug 1592416.

As a workaround, try right-clicking on the Firefox dock icon, choosing Options, and setting "Assign To" to None. I'll attach a screenshot. So far, I have only see this problem when Firefox has been assigned to a particular workspace.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago8 months ago
Flags: needinfo?(haftandilian)
Resolution: --- → DUPLICATE
Duplicate of bug: 1592416
You need to log in before you can comment on or make changes to this bug.