Can't find entity in DTD

RESOLVED DUPLICATE of bug 22942

Status

()

Core
XML
RESOLVED DUPLICATE of bug 22942
16 years ago
16 years ago

People

(Reporter: John D. Ramsdell, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
The URL above names an XML document that includes the %copy; entity.  To find a
definition for this entity, the browser must look at the DTD.  The DTD is in
http://simp.mitre.org/simpdoc/simpdoc10.dtd.  It defines the © entity by
loading http://www.w3.org/TR/xhtml-basic/xhtml-basic10.dtd.  This DTD loads some
files that eventually include http://www.w3.org/TR/xhtml-basic/xhtml-lat1.ent,
which defines ©, however, Mozilla 1.0 fails to display the XML page
claiming it cannot find the defined entity.  Here is the text of the error message.

XML Parsing Error: undefined entity
Location: http://simp.mitre.org/simpdoc/simpdoc.xml
Line Number 48, Column 14:

p>Copyright &copy; 2002 The MITRE Corporation.  All Rights Reserved.</p>
-------------^

SIMP Doc is a DTD and XSLT stylesheet for using XML to produce XHTML documents
with automatically numbered sections and references, and an automatically
generated table of contents.
Mozilla does not have a validating parser and cannot read external entity files.
For workaround in general case, see the duplicate bug and comment 29. We have
hardcoded recognition for some common public identifiers, see list at
http://lxr.mozilla.org/mozilla/source/htmlparser/src/nsExpatDriver.cpp#201

*** This bug has been marked as a duplicate of 22942 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.