[FLOAT] lower float appearing atop higher floats (sometimes)

VERIFIED WORKSFORME

Status

()

P3
minor
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: mozbugs, Assigned: attinasi)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020805
BuildID:    2002080504

The layout of this page is:
- A header div followed by a two column table
- In the second column there is four main divs, all float:left
 - #main, .auxiliary (x2), #footer ( in that order )
  - .auxiliary is width specified ( width: 150px )
- stylesheet is http://mason.gmu.edu/~danders2/ecommportstyle.css
- there is a br clear="all" before the #footer div

Footer occasionally ( most likely these days ) appears atop the other three
elements.  Is there anyway the form in #main is connected with this (because
this only started appearing when I introduced the form)?


Reproducible: Sometimes
Steps to Reproduce:
1. Load page ( notice footer atop #main, .auxiliary divs )
2. Select Basic Page stylesheet ( observe footer at bottom )
3. Select warp stylesheet ( observe footer at bottom )


Actual Results:  #footer appears at top.

Expected Results:  #footer should appear at bottom.

To see what I'm seeing look at http://mason.gmu.edu/~danders2/warpedLayout.gif

Comment 1

16 years ago
Your page has errors. Try using http://validator.w3.org:
http://validator.w3.org/check?uri=http%3A%2F%2Fmason.gmu.edu%2F%7Edanders2%2FwarpedLayout.html&charset=%28detect+automatically%29&doctype=Inline

# Line 1539, column 5:

  </div>
       ^


-->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
sorry for the invalid doc...

after fixing, problem remains... (see same url...)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 3

16 years ago
Uhm...

Even though the validator said it the page was fine, there was a missing closing
tbody tag.  Closing it seemed to do the trick.

Well this isn't my first ( and probably not the last ) invalid bug of mine. 
Sorry for the commotion...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
I'm mift now.  A very similar document is doing well.  But posted ( and twice
fixed ) url is still displaying said behavior.  So rereopening...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

16 years ago
Created attachment 94354 [details]
Testcase

Comment 6

16 years ago
Confirming bug, 2002-08-04-21 (trunk) on Linux.

Seems to be a problem with clearing floaters on initial reflow when there is
a <SCRIPT src="non-existent.js"> involved.

Resizing the window makes layout correct.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows 2000 → All
Summary: lower float appearing atop higher floats (sometimes) → [FLOAT] lower float appearing atop higher floats (sometimes)
(Reporter)

Comment 7

16 years ago
Mats, many thanks for making the testcase and pinpointing the problem.

One small correction.

It's the script tag itself, not a non-existing script reference that is the
cause of the trouble.

Look at 
http://mason.gmu.edu/~danders2/warpedLayoutRealScript.html
(same page, except for  changed script tag.)

It still exhibits problems.  This time, the script exists...
(Reporter)

Comment 8

16 years ago
This page is related and a bit more interesting...

http://mason.gmu.edu/~danders2/warpedLayout2.html

There is no iframe this time.
The problem is exhibited when you open a detail ( click on a details link ) then
click on the ( same, but containing different text ) close details link.

( There will be an alert box before the problem exhibits )

Notice that the span tag DOES NOT HIDE AS ASKED... ( js embeded in page.. )
( and there are no js errors registered in the console... )
(Reporter)

Comment 9

16 years ago
slightly reduced test case.

footer and breaking line not necessary.

http://mason.gmu.edu/~danders2/bug161115v2.html

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future
(Reporter)

Comment 10

16 years ago
This is working for me, now, in
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030411 Phoenix/0.5+
and
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030427

Thanks mystery fixer.  Moz developers ROCK!
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Verified wfm, 2003-04-30-22 trunk Linux.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.