"View Complete Card" followed by "View Condensed Card" problems

VERIFIED DUPLICATE of bug 13927

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 13927
20 years ago
20 years ago

People

(Reporter: sspitzer, Assigned: troy)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

this bug is related to #7307

when viewing a message with a vcard that's too big for the message pane on
linux, if I scroll down to the bottom, and then click on "View Complete Card"
followed by "View Condensed Card" (and repeat) I get weirdness.

see the attached screen shot.

the weirdness goes away if I scroll around, or if I cover the window with
another window and expose it again.

I can reproduce this in viewer, see attachment:  bug.eml
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
What is a .eml file and why is this assigned to layout? We deal with HTML and
XML...
Status: RESOLVED → REOPENED
.eml is the extension we are using for a RFC-822 message.

(Electronic MaiL, I guess?)

.eml files get converted with the mime converter into XML and then sent to
layout.

there is a legit bug here, don't mark it invalid.

re-opening.
it's assigned to layout because it looks like a re-paint isn't happening.
Assignee: troy → sspitzer
Status: REOPENED → NEW
Then I'll reassign the bug to you.

If you're going to assign the bug to layout, then I need a HTML or XML example
that reprouces the problem.

It's more than likely a compositor bug or a Linux platform specific bug. If it
isn't XP reproducible, then it probably isn't layout...
Resolution: INVALID → ---
I'll try to reproduce it on a NT box, and report back.

like the original bug, #7307, I think this may be Linux only, but I'll report
back when I know for sure.

I'll also try to save off the XML / HTML that the emitter produces, so you can
debug from there.

clearing invalid resolution, since its clearly not invalid.
the attached html exhibits the problem on Linux.

load it in viewer, scroll to the bottom, hit the "View Complete Card" followed
by "View Condensed Card" button, and you see it.

testing on windows now to see if the bug is XP...
Assignee: sspitzer → troy
OS: Linux → All
Hardware: PC → All
its an XP bug.  the HTML file I attached shows the problem on Windows and Linux.

re-assign to troy.  funny, I thought that's what I originally did.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
Looks like same issue as 13927 (compositor bug)

*** This bug has been marked as a duplicate of 13927 ***
Status: RESOLVED → VERIFIED
Agreed. Marking as verified duplicate of 13927.
You need to log in before you can comment on or make changes to this bug.