Javascript-based metric converter produces incorrect calculations

RESOLVED DUPLICATE of bug 166752

Status

()

--
major
RESOLVED DUPLICATE of bug 166752
16 years ago
16 years ago

People

(Reporter: douglas.p.collette, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

This site is a Java-based metric converter that produces grossly incorrect
answers when using Mozilla 1.1 Beta.  The Length, Weight and Pressure coversions
work properly in Netscape 4.5 and IE 5.0.  The Volume converter doesn't seem to
work with any browser.

For example, using the Length converter, 25.4 millimeters is calculated to be
55.997 inches.  Also, there are no calculations shown for Meters, Feet and
Yards.  These fields are calculated using Netscape and IE.

Reproducible: Always
Steps to Reproduce:
1. Enter 25.4 in Millimeters window of the Length Conversion Calulator
2. Press the Calculate button
3. 

Actual Results:  1. 55.997 will be displayed in the Inches window

Expected Results:  1. The correct number is 1.0000 inches

I'm using the Lopburi Flat theme and haven't verified if this problem still
occurs with the default theme.

Comment 1

16 years ago
this is java_script_, not java. changing components.
Assignee: joe.chou → jst
Component: Java APIs to WebShell → DOM Level 0
QA Contact: avm → desale
Summary: Java-based metric converter produces incorrect calculations → Javascript-based metric converter produces incorrect calculations

Comment 2

16 years ago
There have been other bug reports about javascript numbers behaving incorrectly.
 Not sure if this is a dupe.

Comment 3

16 years ago
Seems to be working fine with 1.0 branch.
javascript: alert(document.forms[0] == document.forms[1]) gives "true" on this page!

This is very very wrong.... (and leads to all the problems observed)

jkeiser?  Any ideas?
Status: UNCONFIRMED → NEW
Ever confirmed: true
dupping forward to the bug with the fix...

*** This bug has been marked as a duplicate of 166752 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.