Closed Bug 1611645 Opened 1 year ago Closed 10 months ago

"Mozilla Firefox (Private Browsing)" tooltip appears when hovering over browser chrome in private windows, for example over urlbar search suggestions

Categories

(Firefox :: General, defect, P3)

72 Branch
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 78
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- verified

People

(Reporter: mvocom, Assigned: adw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

Open a private window.
Type "Firefox" in the UrlBar.
Hover over the search suggestions.

Actual results:

A "Mozilla Firefox (Private Browsing)" tooltip shows up.

Expected results:

This tooltip is distracting. Do not show it.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar

I cannot reproduce in Nightly on a Mac.
Is this with the update1 pref enabled in 72? does it happen without update1? it's possible the bug was fixed at a later time...
Also, search suggestions in pb windows are obviously enabled.

Flags: needinfo?(mvocom)

(In reply to Marco Bonardo [:mak] from comment #2)

I cannot reproduce in Nightly on a Mac.
Is this with the update1 pref enabled in 72? does it happen without update1? it's possible the bug was fixed at a later time...
Also, search suggestions in pb windows are obviously enabled.

Can you please try it with 72?

The tooltip shows up whether "update1" is enabled or disabled.

Indeed, search suggestions in pb windows are enabled.
I started using the search functionality in the UrlBar in FF 71 when "Show search suggestions in private windows" was introduced

Thank you.

Flags: needinfo?(mvocom)

I can reproduce this on 72 but not on 73 or Nightly. At this point it's too late to port a fix to 72, so I'll mark this as worksforme. If you can reproduce it on 73 or Nightly unlike me, please let us know.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Great. Thank you (for that too :) ).

I can reproduce it on FF 76.

(In reply to Drew Willcoxon :adw from comment #4)

I can reproduce this on 72 but not on 73 or Nightly. At this point it's too late to port a fix to 72, so I'll mark this as worksforme. If you can reproduce it on 73 or Nightly unlike me, please let us know.

Can you please have a look? - I find this behavior quite annoying.
Thank you.

Yes, I can reproduce this on the latest Nightly again. I can see how it can be annoying.

Severity: normal → S3
Status: RESOLVED → REOPENED
Type: enhancement → defect
Ever confirmed: true
Priority: -- → P3
Resolution: WORKSFORME → ---
Status: REOPENED → NEW

The tooltip is shown for every element in chrome that doesn't have its own tooltip, not only the urlbar view, for example spacers in the toolbar or the urlbar input. Setting docElement.title is the problem: https://searchfox.org/mozilla-central/rev/fc91a093e40dde71d10ad219946b8ae775aca9eb/browser/base/content/browser.js#8238

I'm not sure why we're doing that. That code was added in bug 1602808: https://hg.mozilla.org/mozilla-central/rev/5db76e42440f772712bf596a267c03a89d6025d8

Before that, we didn't set title or anything: https://hg.mozilla.org/mozilla-central/annotate/510148b18effcf093100bd89e2f6eaf24c358a08/browser/base/content/browser.js#l8387

And before that, we set the "title" attribute, not the property: https://hg.mozilla.org/mozilla-central/annotate/9223ff1024a67d3d160b75481905a7079031223f/browser/base/content/browser.js#l8949

Setting the attribute has the same effect as setting the property. So maybe bug 1602808 reverted back to this older changeset but set the property instead of the attribute? That would explain why this appeared first, then was fixed, and now is broken again.

Anyway, the window ends up with the correct title (via tabbrowser.updateTitlebar and getWindowTitleForBrowser), so it doesn't seem necessary to set the title on the document element.

Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 78.2 - May 18 - May 31
Points: --- → 2
Component: Address Bar → General
Keywords: regression
Regressed by: 1602808
Summary: UrlBar: do not show "Mozilla Firefox (Private Browsing)" tooltip when hovering over search suggestions → "Mozilla Firefox (Private Browsing)" tooltip appears when hovering over browser chrome in private windows, for example over urlbar search suggestions
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9259663203fe
Don't set documentElement.title in private windows. r=Gijs

Thank you. I appreciate it.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Flags: qe-verify+

Reproduced the issue using Firefox 78.0a1 (20200522213853) on Windows 10x64.
The issue is verified fixed with Firefox 78.0b7 (20200612174529) on Windows 10x64, macOS 10.12 and Ubuntu 18.04. No search tip is displayed in private windows when hovering search results.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.