Closed Bug 1611704 Opened 2 years ago Closed 2 years ago

Right-clicking on the Network Request Details panel causes scrolling to the top.

Categories

(DevTools :: Netmonitor, defect, P3)

74 Branch
defect

Tracking

(firefox-esr68 wontfix, firefox75 wontfix, firefox76 wontfix, firefox77 verified)

VERIFIED FIXED
Firefox 77
Tracking Status
firefox-esr68 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- verified

People

(Reporter: nayinain, Assigned: bomsy)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

  1. Open the Network Monitor (Ctrl+Shift+E).
  2. Select one of the requests.
  3. Adjust the height of the network monitor to ensure that the vertical scroll bar appears in the request details panel.
  4. Scroll the request details panel to the bottom and right-click.

Actual results:

Scroll to the top.

Expected results:

Should not scroll.


Sorry for my bad English.

Has STR: --- → yes

:nayinain, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

Regression window

2020-01-27T13:08:06: INFO : Narrowed inbound regression window from [c49960f2, 5430d7a5] (3 builds) to [d077a01c, 5430d7a5] (2 builds) (~1 steps left)
2020-01-27T13:08:06: DEBUG : Starting merge handling...
2020-01-27T13:08:06: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=5430d7a592d21f5a09d78bdbe9d3d26cc3ef577c&full=1
2020-01-27T13:08:07: DEBUG : Found commit message:
Bug 1547068 - making badges in tree non-interactive as per ui-review. r=mtigley

Depends on D29342

Differential Revision: https://phabricator.services.mozilla.com/D29363

2020-01-27T13:08:07: DEBUG : Did not find a branch, checking all integration branches
2020-01-27T13:08:07: INFO : The bisection is done.
2020-01-27T13:08:07: INFO : Stopped

Has Regression Range: --- → yes
Keywords: regression
Regressed by: 1547068

The priority flag is not set for this bug.
:Honza, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(odvarko)

I can reproduce the issue on my machine, thanks for reporting it!

Honza

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(odvarko)
Priority: -- → P3

Fixed By Bug 1613884

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Assignee: nobody → hmanilla
Target Milestone: --- → Firefox 77
QA Whiteboard: [qa-77b-p2]

Confirmed issue with 74.0a1 2020-01-26 on windows 10.
Fix verified with 77.0 on Windows 10, macOS 10.15.3, Ubuntu 20.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.