Closed Bug 1611945 Opened 8 months ago Closed 21 days ago

The "Browser Toolbox" is wrongly opened instead of the "Multiprocess Browser Toolbox" one on Windows

Categories

(DevTools :: Debugger, defect, P2)

Desktop
Windows
defect

Tracking

(firefox72 affected, firefox73 affected, firefox74 affected)

RESOLVED DUPLICATE of bug 1660776
Tracking Status
firefox72 --- affected
firefox73 --- affected
firefox74 --- affected

People

(Reporter: mcoman, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox Release 72.0.2 - Build ID: 20200117190643
  • Firefox Beta 73.0b10 - Build ID: 20200125104833
  • Firefox Nightly 74.0a1 - Build ID: 20200128092639

[Affected Platforms]:

  • Windows 10 x64

[Prerequisites]:

  • Have a Firefox profile with the following prefs in the "about:config" page:
    • "devtools.chrome.enabled" pref set to "true";
    • "devtools.debugger.remote-enabled" set to "true"

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Press the "Ctrl + Shift + Alt + I" keys and observe the behavior.

[Expected result]:

  • The "Multiprocess Browser Toolbox" window is opened.

[Actual result]:

  • The "Browser Toolbox" is opened instead.

[Notes]:

  • This issue is not reproducible on Mac or Linux.
  • Attached a screen recording of the issue.

Patrick, could you please give us your opinion regarding this issue?

Flags: needinfo?(pbrosset)

Passing this along to Alex.

Flags: needinfo?(pbrosset) → needinfo?(poirot.alex)

The Multiprocess Browser Toolbox is enabled via devtools.browsertoolbox.fission preference.
It is currently only set on Nightly channel:
https://searchfox.org/mozilla-central/source/browser/app/profile/firefox.js#1916-1923

I'm not able to reproduce. I'm wondering if, by using an old profile folder, this pref could be still set to false?
We toggled it to true on Nightly in bug 1588050.
It would be interesting to check what is the value of this preference.

Otherwise, there is something really surprising in your screen record.
It looks like you get the "Browser Content Toolbox" instead of the "(Multiprocess) Browser Toolbox".
The two are spawn by very different functions:
https://searchfox.org/mozilla-central/source/devtools/client/menus.js#99-114
Could it be that Menus implementation is completely broken and mixes menu entries??

Flags: needinfo?(poirot.alex)

The priority flag is not set for this bug.
:pbro, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(pbrosset)
Flags: needinfo?(pbrosset)
Priority: -- → P2

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Debugger

This is super weird.

I cannot reproduce but I've seen it. The only major difference between where it happens and where it doesn't seems to be the machine, hardware somehow?

I've also tried toggling devtools.browsertoolbox.fission and I got no change in which debugger is loaded.

@ochameau, is there more information that we could maybe provide in this bug? Something that might help to have an expedited fix? Our team (Ecosystem QA) is pretty affected by this issue and we can't reliably verify bugfixes in some cases on this important platform.

Flags: needinfo?(poirot.alex)

I'm still not able to reproduce anything close to what is demoed on the GIF.

Again, the "Multiprocess Browser Toolbox" isn't enabled by default on any channel other than Nightly.
We are actively discussing about enabling it on all other channels (bug 1625937).

So on any channel other than Nightly, you would have to toggle devtools.browsertoolbox.fission to true.
Also, we were having an issue with this pref on old release (FF 72 and before, bug 1603361), where toggling it wouldn't necessarily enable the "multiprocess" toolbox.
I tested on Windows with firefox 77 and 79, it works fine for me.

If you have some STR, may be going from an empty profile. It may help.

Flags: needinfo?(poirot.alex)

Hi Alexandre,

We have investigated this issue a bit further and found out that it seems to be caused by an environment variable that we have to set in order to be able to enroll in the recipes created on the Stage Normandy server. What we are doing is the following:

  • On Windows, we set a System Variable named XPCSHELL_TEST_PROFILE_DIR with the value set to foo.
  • On macOS, and Linux we have to write the following line in the terminal export XPCSHELL_TEST_PROFILE_DIR=foo and then start the Firefox browser from the same terminal.
    Without this variable set, the "Multiprocess Browser Toolbox" is displayed as expected.

@Alexandre, could you please set the same variable as us and see if the issue is also reproducible on your end?

Flags: needinfo?(poirot.alex)

Ok, so I'll duplicate this bug as this is the same story as bug 1660776.

Status: NEW → RESOLVED
Closed: 21 days ago
Flags: needinfo?(poirot.alex)
Resolution: --- → DUPLICATE
Duplicate of bug: 1660776
You need to log in before you can comment on or make changes to this bug.