Mozilla will not load external style sheet in transitional documents

RESOLVED WONTFIX

Status

()

Core
CSS Parsing and Computation
RESOLVED WONTFIX
16 years ago
15 years ago

People

(Reporter: arne.proffe, Assigned: dbaron)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
It is stated:
"When a page using a strict document type declaration (e.g. HTML 4.01 Strict) 
links to an external style sheet (using <link>, @import, etc.) Mozilla
will load the style sheet only if it is served with a MIME type of "text/css"."

This statement is not true, it applies also to transitional documents which is 
very annoying and limits the use of Mozilla. It is very difficult to influence 
an ISP to change his server.

Comment 1

16 years ago
I don't know where that quote comes from, but the document
<http://www.mozilla.org/docs/web-developer/quirks/doctypes.html> clearly shows a
variety of transitional DOCTYPES that will trigger Standards mode or Almost
Standards mode.

It also shows that HTML 4.0 or 4.01 DOCTYPEs with no URL in the DOCTYPE will
give you quirks mode and looser CSS/MIME behavior.

Really though, the ISP needs to fix its server.  Not much point to having MIME
types if the admins can't configure them correctly.

Since the browser is behaving correctly, I would suggest that the only bug here
is identifying the document where this quote comes from (presuming it's
something on the mozilla.org site) and fixing it.  You could also file a
separate tech evangelism bug about getting the ISP to fix its server.
remove the URL from the DOCTYPE, that helps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 3

16 years ago
The quote comes from the 1.0 release notes.  I've raised bug 161257 to get 
those fixed.
You need to log in before you can comment on or make changes to this bug.