Closed Bug 1612689 Opened 3 years ago Closed 3 years ago

[Wayland][Gnome] Nightly update started crashing my Gnome-shell

Categories

(Core :: Widget: Gtk, defect, P3)

x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: popovic.marko, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

At random times Firefox on Wayland started crashing my whole Gnome shell today, especially after wanting to re-organize the tabs or drag and drop something from Nautilus into browser.

Not sure what changed so drastically but I'm pretty sure that it was nightly update, I was forced back to XWayland and haven't had a crash since. It was also the only thing I updated in the last 2 days.

Actual results:

Whole gnome shell crashes and bring me to login screen.

Expected results:

Browser continues working without a crash.

Severity: normal → critical
Component: General → Widget: Gtk
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

UPDATE: Just had a crash on the same version of Firefox nightly on my Laptop.

One machine is Intel i5 6600/ AMD RX 5700 XT with Mesa20/LLVM-9.0.1 and second one is Intel i5 8550u with IntelHD graphics and Mesa 19.3 Stable, which kinda excludes any regressions on other factors like GPU drivers etc, so it's definitely Firefox nightly - wayland version.

UPDATE 2: The easiest way to reproduce the issue seems to be, casually browse web in multiple tabs for like half an hour and then at one point try dragging the current tab across the screen. Gnome-Shell crash is almost guaranteed.

Please at least revert the update that might have caused the issue to appear in the first place... XWayland's performance is insanely sub-optimal compared to native wayland.

Can you please provide any crash data? You should find them at about:crashes. Please submit them and attach links here. Thanks.

Blocks: wayland
Flags: needinfo?(popovic.marko)
Priority: -- → P3

It's likely caused by https://phabricator.services.mozilla.com/D60853 from bug 1604048, as that's the biggest rework of DnD lately. The fact that it crashes the shell means that there's definitely a bug in GS/Mutter, as it should never crash no matter what a client does. Can you add which version of GS/Mutter you have?

If possible, a stack trace would of the GS crash would be great to have.

As robert.mader said, crashes aren't recorded in about:crashes because it seems that Firefox nightly provokes gnome shell crash and not browser crash.
I'm very inexperienced when it comes to debugging but I'm ready to help if you guys can guide me through it. I just thought posting a bug report would be a neccessity since the bug is quite critical.

Flags: needinfo?(popovic.marko)

╭─░▒▓    ~   ✔  15:03:18  ▓▒░
╰─ gnome-shell --version
GNOME Shell 3.34.1
╭─░▒▓    ~   ✔  15:03:22  ▓▒░
╰─ mutter --version
mutter 3.34.1
Copyright © 2001-2011 Havoc Pennington, Red Hat, Inc., and others
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

My Mutter and gnome-shell versions...

(In reply to Marko from comment #6)

╭─░▒▓    ~   ✔  15:03:18  ▓▒░
╰─ gnome-shell --version
GNOME Shell 3.34.1
╭─░▒▓    ~   ✔  15:03:22  ▓▒░
╰─ mutter --version
mutter 3.34.1
Copyright © 2001-2011 Havoc Pennington, Red Hat, Inc., and others
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

My Mutter and gnome-shell versions...

This is very helpful already. Both version are quite a bit behind (we are currently at 3.34.3 and 3.34.4 is about to be released). So there are good chances that the bug you are seeing is already fixed. So the first step would be to contact your distribution and ask to update their GS/Mutter packages.

On which distribution is that?

Pop!_OS 19.10. Do you perhaps have any clues if there were any such bugs documented in prior mutter/shell versions like 3.34.1?

@robert.mader I installed testing repo for Pop!_OS which comes with Gnome-Shell 3.34.3 so I will report back if the bug is still here...

(In reply to robert.mader from comment #7)

(In reply to Marko from comment #6)

╭─░▒▓    ~   ✔  15:03:18  ▓▒░
╰─ gnome-shell --version
GNOME Shell 3.34.1
╭─░▒▓    ~   ✔  15:03:22  ▓▒░
╰─ mutter --version
mutter 3.34.1
Copyright © 2001-2011 Havoc Pennington, Red Hat, Inc., and others
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

My Mutter and gnome-shell versions...

This is very helpful already. Both version are quite a bit behind (we are currently at 3.34.3 and 3.34.4 is about to be released). So there are good chances that the bug you are seeing is already fixed. So the first step would be to contact your distribution and ask to update their GS/Mutter packages.

On which distribution is that?

Seems that you're right, I've been stressing it out now on 3.34.3 and haven't been able to reproduce the crash so far. If it occurs again I will let you guys know during the day. Otherwise we should probably just encourage everyone to use the "unstable" software repositories xD

(In reply to Marko from comment #10)

Seems that you're right, I've been stressing it out now on 3.34.3 and haven't been able to reproduce the crash so far. If it occurs again I will let you guys know during the day. Otherwise we should probably just encourage everyone to use the "unstable" software repositories xD

Or encourage your distribution to push stable updates to their stable repo.... :P
I mean, we're talking about dot-releases there. Distributions should probably trust upstream that these updates are rather "stable".
Fedora and Arch push GS updates much faster btw.

(In reply to robert.mader from comment #11)

Or encourage your distribution to push stable updates to their stable repo.... :P
I mean, we're talking about dot-releases there. Distributions should probably trust upstream that these updates are rather "stable".
Fedora and Arch push GS updates much faster btw.

Yes I am aware of that, I've used Fedora for quite a while and I really liked it, but I really like Pop!_OS because of the polish they add for laptops like battery life and similar. Hence why I use it instead. But I will try and reach out to Pop!_OS devs in order to push stable point releases out faster :)

UPDATE: No crashes recorded today after updating the shell to 3.34.3. I think it's safe to close this bug report.

Thanks!

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1622527

(In reply to Robert Mader [:rmader] from comment #7)

(In reply to Marko from comment #6)

╭─░▒▓    ~   ✔  15:03:18  ▓▒░
╰─ gnome-shell --version
GNOME Shell 3.34.1
╭─░▒▓    ~   ✔  15:03:22  ▓▒░
╰─ mutter --version
mutter 3.34.1
Copyright © 2001-2011 Havoc Pennington, Red Hat, Inc., and others
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

My Mutter and gnome-shell versions...

This is very helpful already. Both version are quite a bit behind (we are currently at 3.34.3 and 3.34.4 is about to be released). So there are good chances that the bug you are seeing is already fixed. So the first step would be to contact your distribution and ask to update their GS/Mutter packages.

On which distribution is that?

Ubuntu 19.10 is also affected by this bug

(In reply to susenoaditya from comment #16)

Ubuntu 19.10 is also affected by this bug

Thx. Unfortunately they are still on Mutter 3.34.1 and both the Wayland session and the Firefox Wayland backend are not enabled by default there so it's a low priority for them - hopefully that will change with Ubuntu 20.10.

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

(In reply to Robert Mader [:rmader] from comment #17)

(In reply to susenoaditya from comment #16)

Ubuntu 19.10 is also affected by this bug

Thx. Unfortunately they are still on Mutter 3.34.1 and both the Wayland session and the Firefox Wayland backend are not enabled by default there so it's a low priority for them - hopefully that will change with Ubuntu 20.10.

Well, I have got the mutter 3.34.3 update from Ubuntu today and can confirm that this Bug is now Disappear

You need to log in before you can comment on or make changes to this bug.