Closed Bug 1612931 Opened 6 months ago Closed 4 months ago

Debugger does not allow to set a breakpoint on non-JS script

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox-esr68 unaffected, firefox74 wontfix, firefox75 wontfix, firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- fixed

People

(Reporter: yury, Assigned: loganfsmyth)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The WebAssembly breakpoint are getting rejected with "Action setBreakpointPositions had an exception: Error: "Protocol error (unknownError): script does not refer to a JS script""

STR:

  1. Open Debugger tab and https://yurydelendik.github.io/old-man-sandbox/gcd/gcd.html
  2. Refresh the page (if Debugger was opened after the page was loaded)
  3. Navigate to https://yurydelendik.github.io/old-man-sandbox/gcd/gcd.rs in the Source panel
  4. Set breakpoint on the line 6

Expected: breakpoint is set
Actual: breakpoint is not set, and the error is shown in the browser console

Possible regression from https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=473309c218b720f2d606d491e44f853e79115aac&tochange=4b654c4b2d524c3b616aa017b3ec340b4235682b

No longer blocks: 1598180
Regressed by: 1598180

The priority flag is not set for this bug.
:jlast, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jlaster)

I can reproduce the issue on my machine.

Also the error in the Browser console is:

Action setBreakpointPositions had an exception: Error: "Protocol error (unknownError): script does not refer to a JS script"
    onPacket resource://devtools/shared/protocol/Front.js:294
    DevTools RDP*request resource://devtools/shared/protocol/Front.js:232
    name resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:49
    getSourceActorBreakpointPositions resource://devtools/client/debugger/src/client/firefox/commands.js:450
    actorBps resource://devtools/client/debugger/src/actions/breakpoints/breakpointPositions.js:127
    _setBreakpointPositions resource://devtools/client/debugger/src/actions/breakpoints/breakpointPositions.js:127
    action resource://devtools/client/debugger/src/actions/breakpoints/breakpointPositions.js:221
    memoizeableAction resource://devtools/client/debugger/src/utils/memoizableAction.js:51
    memoizeableAction resource://devtools/client/debugger/src/utils/memoizableAction.js:57
    thunk resource://devtools/client/debugger/src/actions/utils/middleware/thunk.js:29
    dispatch Redux
    addBreakpoint resource://devtools/client/debugger/src/actions/breakpoints/modify.js:95
    thunk resource://devtools/client/debugger/src/actions/utils/middleware/thunk.js:29
    dispatch Redux
    addBreakpointAtLine resource://devtools/client/debugger/src/actions/breakpoints/index.js:344
    thunk resource://devtools/client/debugger/src/actions/utils/middleware/thunk.js:29
    bindActionCreator Redux
    Editor resource://devtools/client/debugger/src/components/Editor/index.js:227
    me chrome://devtools/content/shared/sourceeditor/codemirror/codemirror.bundle.js:1
    ya chrome://devtools/content/shared/sourceeditor/codemirror/codemirror.bundle.js:1
    ba chrome://devtools/content/shared/sourceeditor/codemirror/codemirror.bundle.js:1
    ga chrome://devtools/content/shared/sourceeditor/codemirror/codemirror.bundle.js:1
Priority: -- → P3

Jason, can you please verify that bug 1598180 caused the regression?

Honza

Assignee: nobody → loganfsmyth
Status: NEW → ASSIGNED

I can verify that https://bugzilla.mozilla.org/show_bug.cgi?id=1598180 introduced this because before that we only called getChildScripts in contexts where we'd already verified that a file was not wasm.

Flags: needinfo?(jlaster)
Pushed by loganfsmyth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/30a0211c383f
Stop calling getChildScripts on WASM scripts. r=jlast
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
You need to log in before you can comment on or make changes to this bug.