Loading pages requested by other applications in tabs not working.

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: fivus6, Assigned: sfraser_bugs)

Tracking

({regression})

Details

(Reporter)

Description

17 years ago
Build ID: 20020080605.  I've seen it in todays build, don't know when it
appeared over the weekend.  Using other applications to open URL's (Mail &
Slashdock tested) it changes focus to Navigator but does not open a new tab or
the requested URL.  Changing the setting to not open links from other
applications in new tabs, just in new windows still works.

Comment 1

17 years ago
so this is a regression?
Keywords: regression

Comment 2

17 years ago
*** Bug 161327 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
regression,->pinkerton
Assignee: saari → pinkerton

Updated

17 years ago
Blocks: 147975

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
over to simon, cc'ing bryner (both checked in this weekend)
Assignee: pinkerton → sfraser
(Assignee)

Comment 5

17 years ago
I probably broke this.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

17 years ago
I can't reproduce this. Please try a recent nightly build, and give explicit
steps to reproduce (including stating what your pref settings are in the Tabbed
Browsing prefs tab.
(Reporter)

Comment 7

17 years ago
Re-downloaded the build via ChimeraKnight 1.1 today.  Build ID: 2002080605. 
Problem still exists.  On new dual GHz G4, OS 10.1.5.  I have tried all settings
in the Tabs pref, but usually I have everything checked.  The problem only
happens when have the "Loading a page requested by another application" checked.

Steps to reproduce:
1. Turn on "Loading a page requested by another application" pref.  
2. Use other application to send a URL to default browser (this must be set in
the  Internet System Prefs to Chimera) I use OS X Mail and Slashdock.
3. Clickon link.  Chimera window comes to front, but does not go to that page in
a new tab (even if tab is not supposed to load in background).
4. Change Tabs pref to turn off  "Loading a page requested by another
application".  
5. Try link in other app.  It will load in a new Navigator window.

Comment 8

17 years ago
Build ID is 2002080605, dated 8/6/2002 (the most recent nightly that I can see).
Make sure you are reading this comment in your email client, not reading it in
Bugzilla using Chimera. 
1. Set Preferences --> Navigation --> Tabbed Browsing --> "Loading a page
requested by another application" to checked in Chimera.
2. Load a page in Chimera (www.cnn.com, for instance).
3. Click on this link in the email: http://www.slashdot.org
4. Focus will go to Chimera, then nothing.
5. Set Preferences --> Navigation --> Tabbed Browsing --> "Loading a page
requested by another application" to UNchecked in Chimera.
6. Load a page in Chimera (www.cnn.com, for instance).
7. Click on this link in the email: http://www.slashdot.org
8. A new Chimera window will come up, and Slashdot will load.

Note that the requested URL will ALWAYS load correctly if Chimera is not
running, and is your default browser, regardless of setting.
(Assignee)

Comment 9

17 years ago
Still works fine in my current developer build. Wait for the 8/7 nightly, and
test again.

Comment 10

17 years ago
It may be fixed in today's build, but the latest publicly available build is
still the same one as yesterday's.  That could be why we are able to reproduce
the problem today, while Simon can't.
(Reporter)

Comment 11

17 years ago
Problem resolved in build 2002080905.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
Verified in the 2002-08-21-05 NB.
Status: RESOLVED → VERIFIED

Updated

17 years ago
No longer blocks: 147975
You need to log in before you can comment on or make changes to this bug.