Closed Bug 1613327 Opened 9 months ago Closed 8 months ago

Crash in [@ @0x0 | _PR_NativeRunThread | pr_root]

Categories

(NSPR :: NSPR, defect, P3)

Unspecified
Windows 7
defect

Tracking

(firefox-esr68 wontfix, firefox72 wontfix, firefox73 wontfix, firefox74 wontfix)

RESOLVED INVALID
Tracking Status
firefox-esr68 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix

People

(Reporter: pascalc, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-e27b4983-4863-446f-a99d-874c40200204.

Top 6 frames of crashing thread:

0  @0x0 
1 nss3.dll _PR_NativeRunThread nsprpub/pr/src/threads/combined/pruthr.c:399
2 nss3.dll pr_root nsprpub/pr/src/md/windows/w95thred.c:139
3 ucrtbase.dll o_strcat_s 
4 kernel32.dll BaseThreadInitThunk 
5 ntdll.dll RtlUserThreadStart 

Low volume crasher on 74 nightly but 73 beta and 72 release have hundred of crashes.

Doesn't seem to be a bug inside NSPR. The API is called parameters with either a null thread start function, or null parameters, and it crashes dereferencing the parameters.

The priority flag is not set for this bug.
:KaiE, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(kaie)

Not a bug in NSPR.

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(kaie)
Priority: -- → P3
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.