Closed Bug 1613339 Opened 10 months ago Closed 10 months ago

Switch to tab option is displayed when there is no tab to switch to

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 555694
Tracking Status
firefox74 --- wontfix

People

(Reporter: simona.marcu, Unassigned)

Details

Attachments

(1 file)

Attached image switchToTab.gif

Mozilla/5.0 (X11; Linux i686; rv:74.0) Gecko/20100101 Firefox/74.0
Build ID: 20200204214324

Affected versions

  • Nightly 74.0a1

Affected platforms

  • Ubuntu 16.04
  • Windows 10 x64
  • Mac OS X 10.15

Steps to reproduce

  1. Launch Firefox with a new profile.
  2. Navigate to: https://www.facebook.com/
  3. Click in the address bar.

Expected result

  • Topsites suggestions are properly displayed, and Facebook is one of them.

Actual result

  • Facebook along with "switch to tab" is shown, even if I am in the Facebook tab and no other tab with Facebook is opened in the browser.

Please see the attached video for more details.

This is intended behavior.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → INVALID

This is related to bug 555694, that was complicate to fix in the old world, now it may be much easier by passing the current tab url in the QueryContext. It should not be a switch to tab entry, it should be a normal entry.

See Also: → 555694
No longer blocks: urlbar-update-1
Resolution: INVALID → DUPLICATE
See Also: 555694
Duplicate of bug: 555694
You need to log in before you can comment on or make changes to this bug.