Closed Bug 1613397 Opened 9 months ago Closed 9 months ago

Crash in [@ mozilla::CrossProcessSemaphore::Create] on OS X

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: sg, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-cbabaab4-95d7-404a-a5d4-99f620200205. This crash happens on OS X only, since CrossProcessSemaphore is not implemented there per Bug 1553691.

Top 10 frames of crashing thread:

0 XUL mozilla::CrossProcessSemaphore::Create ipc/glue/CrossProcessSemaphore_unimplemented.cpp:15
1 XUL mozilla::webgl::ProducerConsumerQueue::Create dom/canvas/ProducerConsumerQueue.h:1407
2 XUL mozilla::webgl::ProducerConsumerQueue::Create dom/canvas/ProducerConsumerQueue.h:1369
3 XUL mozilla::ClientWebGLContext::CreateHostContext dom/canvas/ClientWebGLContext.cpp:691
4 XUL mozilla::ClientWebGLContext::SetDimensions dom/canvas/ClientWebGLContext.cpp:681
5 XUL mozilla::dom::CanvasRenderingContextHelper::UpdateContext dom/canvas/CanvasRenderingContextHelper.cpp:221
6 XUL mozilla::dom::CanvasRenderingContextHelper::GetContext dom/canvas/CanvasRenderingContextHelper.cpp:179
7 XUL mozilla::dom::HTMLCanvasElement_Binding::getContext dom/bindings/HTMLCanvasElementBinding.cpp:294
8 XUL bool mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy, mozilla::dom::binding_detail::ThrowExceptions> dom/bindings/BindingUtils.cpp:3151
9 XUL js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:562

Flags: needinfo?(jgilbert)

This is another bug where I don't see the webgl.out-of-process pref set, but we're clearly in the out-of-process branch. I'm somewhat suspecting that maybe the crash reporter isn't seeing the up-to-date pref settings.

Flags: needinfo?(jgilbert)

Assuming we're here because of webgl.out-of-process:true, this is expected behavior, and this is RESOLVED INVALID.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → INVALID
See Also: → 1613754
You need to log in before you can comment on or make changes to this bug.