Closed Bug 1613409 Opened 2 years ago Closed 2 years ago

CFCA: Repeated unexplained delays in providing timely status updates

Categories

(NSS :: CA Certificate Compliance, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ryan.sleevi, Assigned: sunny_bxl)

References

(Regression)

Details

(Whiteboard: [ca-compliance])

In Bug 1524733, Bug 1532113, and Bug 1532559, CFCA failed to provide timely updates on their incidents.

Given the systemic pattern, this is a request for CFCA to provide an incident report about what it is doing to ensure that the Mozilla Community is provided timely updates on all incidents going forward, to ensure CFCA adheres to Mozilla's expectations in Keeping Us Informed

Assignee: wthayer → sunny_bxl
Status: NEW → ASSIGNED
Whiteboard: [ca-compliance]
Regressed by: 1524733, 1532113, 1532559

(In reply to Ryan Sleevi from comment #0)

In Bug 1524733, Bug 1532113, and Bug 1532559, CFCA failed to provide timely updates on their incidents.

Given the systemic pattern, this is a request for CFCA to provide an incident report about what it is doing to ensure that the Mozilla Community is provided timely updates on all incidents going forward, to ensure CFCA adheres to Mozilla's expectations in Keeping Us Informed

Ryan: Thanks for pointing out the problems we might have, I think there may be some misunderstanding.

After my reply (Bug 1532113 comment #12 and Bug 1532559 comment #15 ), I didn't receive any reply, so I focused on the system development, I think it would be more credible for you to see a complete system. I had planned to update the status and submit the final report after the system was officially used. New system development may take a long time.

For the above two reasons, I didn’t provide timely updates.

Here are some importint time points of our work, we have been actively solving problems:

July 13, 2019: We started the development of automated ordering system
September 10, 2019: The first version has been developed.
September 27, 2019: The test system been deployed
Between October and December: Make multiple BUG fixes
December 9, 2019: We started the production system deployment, it ends at the end of December.

According to our previous plan, this system will used in some important customers first, so during the period of January 2020, we communicated with some customers, training them how to use this system, it will officially used on February 1 (After Spring Festival).

However, due to the special situation in China , most enterprises haven't started work yet, so the plan may be delayed, it is expected to be put into use formally by the end of February or March or some other times, it depending on the '2019-nCoV' development trend.

Ryan,

I just want to tell you that the system has been used on March 2.

Since my last reply, I have not received any comments. I would like to ask whether this question has been explained clearly and whether it can be closed.

Flags: needinfo?(ryan.sleevi)

Sorry, this mail thread ended up mis-filtered. Your response in Comment #1 was about the prior issues.

My question was about making sure that bugs undergo timely (weekly) updates, which Comment #1 doesn't seem to address?

Flags: needinfo?(ryan.sleevi)

(In reply to Ryan Sleevi from comment #3)

Sorry, this mail thread ended up mis-filtered. Your response in Comment #1 was about the prior issues.

My question was about making sure that bugs undergo timely (weekly) updates, which Comment #1 doesn't seem to address?

Hi, Ryan

I had some misconceptions about the process ago. I thought it was a question and answer format, where someone asks and then someone answers it, if no one asks questions for a long time, the discussion maybe over.

I read the Mozilla expects weekly updates again (https://wiki.mozilla.org/CA/Responding_To_An_Incident#Keeping_Us_Informed).

I'm sure i fully understand how to deal the follow-up now. If the remediation steps take a long time, more than a week, I should state the next update time, get confirmation from the Mozilla representative, not just waiting. Then update the status before the "Next Update" time.

Flags: needinfo?(wthayer)

It appears that all questions have been answered and remediation is complete.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(wthayer)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.