Closed Bug 1614591 Opened 8 months ago Closed 7 months ago

Warning: Failed prop type: Invalid prop `isClosed` of type `boolean` supplied to `FrameListContent`, expected `function`

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(firefox75 fixed)

RESOLVED FIXED
Firefox 75
Tracking Status
firefox75 --- fixed

People

(Reporter: Honza, Assigned: pranavpandey1998official)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

STR:

  1. Open DevTools & select the Network panel & open the Browser Console
  2. Load http://janodvarko.cz/test/websockets/
  3. Click the Connect button
  4. Click the Send button a few times
  5. Select the WS 101 request
  6. Select the Messages side panel
  7. Check out the Browser Console it shows the following error:
Warning: Failed prop type: Invalid prop `isClosed` of type `boolean` supplied to `FrameListContent`, expected `function`.
    in FrameListContent
    in Unknown (created by Connect(Component))
    in Connect(Component) (created by WebSocketsPanel)
    in div (created by SplitBox)
    in div (created by SplitBox)
    in SplitBox (created by WebSocketsPanel)
    in div (created by WebSocketsPanel)
    in WebSocketsPanel
    in VisibilityHandler
    in Unknown (created by Connect(Component))
    in Connect(Component) (created by TabboxPanel)
    in div (created by Panel)
    in Panel (created by TabboxPanel)
    in div (created by Tabs)
    in div (created by Tabs)
    in div (created by Tabs)
    in Tabs (created by Sidebar)
    in Sidebar (created by Tabbar)
    in div (created by Tabbar)
    in Tabbar (created by TabboxPanel)
    in TabboxPanel (created by NetworkDetailsPanel)
    in div (created by NetworkDetailsPanel)
    in NetworkDetailsPanel
    in VisibilityHandler
    in Unknown (created by Connect(Component))
    in Connect(Component) (created by MonitorPanel)
    in div (created by SplitBox)
    in div (created by SplitBox)
    in SplitBox (created by MonitorPanel)
    in div (created by MonitorPanel)
    in MonitorPanel
    in VisibilityHandler
    in Unknown (created by Connect(Component))
    in Connect(Component) (created by App)
    in div (created by DropHarHandler)
    in DropHarHandler (created by App)
    in div (created by App)
    in App
    in VisibilityHandler
    in Unknown (created by Connect(Component))
    in Connect(Component)
    in Provider

when I am clicking on connect button I am getting 400 bad request

Flags: needinfo?(odvarko)

Yeah, it happens sometimes when connecting to: ws://echo.websocket.org/
You might try another WS server

Or you might try this page:
http://signalr-samples.azurewebsites.net/hubs.html

Any page that generates some WS traffic can be used to repro the issue.

Honza

Flags: needinfo?(odvarko)

Also note that you need ac_add_options --enable-debug-js-modules in your .mozconfig

Honza

i still cannot reproduce it ,

Flags: needinfo?(odvarko)

I have reproduced it thanks for help

Great! (let me know if you want to me assigned)

Honza

Flags: needinfo?(odvarko)
Assignee: nobody → pranavpandey1998official
Status: NEW → ASSIGNED
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a7f4d65cd26
changed prop type of isClosed to bool. r=Honza
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75
You need to log in before you can comment on or make changes to this bug.