Closed Bug 1614705 Opened 2 years ago Closed 2 years ago

Plugin crashed on Netflix (Widevine issue ?)

Categories

(Core :: Audio/Video: GMP, defect, P3)

73 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1614535
Tracking Status
firefox73 --- fixed
firefox74 --- fixed
firefox75 --- fixed

People

(Reporter: panieravide, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

This is my first bug report, so sorry if I miss anything. I'm using Firefox 73.0 under Arch Linux 64 bits, with DRM option enabled and Widevine (4.10.1582.2) + OpenH264 (1.8.1.1) installed and enabled. Freshly updated today from distribution repository.

  • Go to netflix.com
  • Try to watch any video

Actual results:

Popup bar appears saying "Plugin crashed" (bug reports ID 115e8b0c-12e9-c0bd-9336-8d6d5ef66423 and 1ab1eb9c-e262-511a-ce77-85234114f27d). Web browser console gives these logs :

MediaKeySystemAccess::GetKeySystemStatus(com.widevine.alpha) result=available msg=''
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIInterfaceRequestor.getInterface] network-response-listener.js:84
MediaKeySystemAccess::GetKeySystemStatus(com.widevine.alpha) result=available msg=''
MediaKeys::Init() promise rejected 0x80004005 'NS_ERROR_FAILURE (0x80004005) - GMPService::operator() failed since GetContentParent rejects the promise with reason NS_ERROR_FAILURE (0x80004005) - GeckoMediaPluginServiceChild::GetContentParent SendLaunchGMPForNodeId failed with description (Process has not loaded.).'

Expected results:

Video should play nicely, like it was doing before update

Crash Signature: [@ mozilla::gmp::GMPChild::ProcessingError ]
Keywords: crash, regression
OS: Unspecified → Linux
Component: Untriaged → Audio/Video: GMP
Product: Firefox → Core
Flags: needinfo?(bvandyk)

Hi, thanks for your report. When you say this worked nicely before updating, is that updating from Firefox 72 to 73?

Could you try setting the environment variable MOZ_DISABLE_GMP_SANDBOX=1 prior to running Firefox and letting me know if that impacts the issue? That variable will disable the Widevine sandbox and give us an idea if the issue you're encountering is due to a sandboxing issue.

Flags: needinfo?(bvandyk) → needinfo?(panieravide)
Priority: -- → P3

Could you try setting the environment variable MOZ_DISABLE_GMP_SANDBOX=1 prior to running Firefox and letting me know if that impacts the issue? That variable will disable the Widevine sandbox and give us an idea if the issue you're encountering is due to a sandboxing issue.

I can confirm that setting the MOZ_DISABLE_GMP_SANDBOX system variable fixes the issue.

Hello,
Thanks for your answers. Setting MOZ_DISABLE_GMP_SANDBOX=1 solves the issue also for me. Before update I was using Firefox 72.x (can't say which minor version exactly).
Regards.

Flags: needinfo?(panieravide)

I am also observing this crash while using spotify.
Bug report here: https://crash-stats.mozilla.org/report/index/4e0c3ffc-46ee-41ad-81ad-2e48f0200212

I can also confirm that setting MOZ_DISABLE_GMP_SANDBOX=1 fixes the issue

This sounds very much like bug 1614535 that was fixed in nightly today.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1614535
You need to log in before you can comment on or make changes to this bug.