Closed Bug 1614984 Opened 3 years ago Closed 3 years ago

Some searches are incorrectly interpreted as URLs

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1566499

People

(Reporter: gcp, Unassigned)

References

Details

  1. Enable Omnibar/Megabar (the default now)
  2. Enter "105m/60s"

Expected result:

Google search, which gives the correct answer.

Actual result:

Firefox "completes" this to http://www.105m.com/60s, which a) Is nonsensical b) Does not exist. The domain 105m.com doesn't even exist.

Chrome works correctly.

I think the www and .com are getting added in docshell due to URI fixup on load, here: https://searchfox.org/mozilla-central/rev/1db5ef59eba65d32d6a29a494e87b6078453e559/docshell/base/nsDocShell.cpp#6293

But even before that, as far as the address bar is concerned, it's still trying to visit http://105m/60s. So this is similar to bug 1610865. I'd be surprised if there aren't other similar older bugs.

As a workaround, you can type "? 105m/60s" to force a search.

Type: enhancement → defect
OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
See Also: → 1610865
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.