Status

--
critical
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: sfraser_bugs, Assigned: bryner)

Tracking

({hang})

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I'm seeing hangs now when doing FTP downloads, which I haven't seen before. I've
seen them on a dual CPU machine; haven't tried to repro on a single CPU machine.
They've been happening for the last couple of days.
(Reporter)

Comment 1

16 years ago
Created attachment 94357 [details]
Sampler report from hung chimera
(Reporter)

Comment 2

16 years ago
Blocker. I can't download new builds.
Severity: normal → blocker
(Assignee)

Comment 3

16 years ago
wtc, I'm guessing from the sampler report that this is some kind of pthread
deadlock, and it coincidentally happened when I checked in the patch from bug
153525 for building on Jaguar.  Any ideas?

Comment 4

16 years ago
bryner: I have no idea.  Thread_0's stack in the sampler
report looks incorrect.

Comment 5

16 years ago
->bryner as the current best guess
Assignee: saari → bryner

Updated

16 years ago
Blocks: 147975
(Assignee)

Comment 6

16 years ago
Adjusting summary, as I just reproduced this on a single-CPU machine.

wtc: It's unclear to me exactly what the implications are of #defining
PT_NOSIGTIMEDWAIT.  It certainly causes different code to be hit in ptthread.c.
 Could this cause some kind of thrashing when switching threads, or anything
like that?
Summary: Hang during download on dual CPU machine → Hang during download
(Assignee)

Comment 7

16 years ago
I was also able to reproduce this problem with my original patch from bug
153525, where there should be no change at all for NSPR on OS 10.1.  This leads
me to think that the problem existed before these changes landed.  I'll do some
more testing on older builds.

Comment 8

16 years ago
FWIW, WorksForMe using Chimera/2002080605.
is this still happening for folx?
Component: General → Downloading
Keywords: hang
QA Contact: winnie → petersen

Comment 10

16 years ago
WFM too. I'm using a Power Mac Dual 800 mhz and haven't seen this problem in
latest builds.
(Reporter)

Comment 11

16 years ago
I haven't seen this for ages. WFM?
Severity: blocker → normal

Comment 12

16 years ago
Hum...I can't seem to reproduce this on some FTP sites I found linked off
FreeBSD.org.  I'm not having issues...

Updated

16 years ago
Severity: normal → critical

Comment 13

16 years ago
WFM by consensus
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
No longer blocks: 147975
(Reporter)

Comment 14

16 years ago
This has come back to bite us in the ass.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 15

16 years ago
*** Bug 184934 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 16

16 years ago
It's either deadlocking, or iterating in nsPipe::GetReadSegment:

http://lxr.mozilla.org/mozilla1.0/source/xpcom/io/nsPipe2.cpp#243

It doesn't look like deadlock with another thread; the socket transport thread
is blocked in poll().

Comment 17

16 years ago
I can consistently repro by trying to download the Google API's:

http://www.google.com/apis/download.html

Don't know if this is redirected to an FTP download or not.

Using 1.2.1 on Win2000 -- should this be a separate bug for non-MacOSX issues?
(Reporter)

Comment 18

16 years ago
This bug is specific to Chimera on Mac OS X. Please file a separate bug for your
case.

Comment 19

15 years ago
I can't reproduce this bug with 2003080802 build.

I'm capable of downloading builds of Camino from the ftp server
(ftp://ftp.mozilla.org/pub/camino/nightly/latest/, Comment #2?) and downloading
the Google api's using the url given in Comment #17 works just fine to. 

Comment 20

15 years ago
WFM also, using the indicated test cases

Comment 21

15 years ago
WFM also, using the indicated test cases: Build ID: 2003081202

Comment 22

15 years ago
I'm going to resolve WFM (again & with a little hesistation)... 

closest thing to this behavior i've seen... think late spring... downloading
nighlies regularly failed but that was due to issues with dead ftp servers
somewhere in the cluster/round robin/whatever and had different symptoms entirely
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.