Last Comment Bug 16153 - Votes should be distributed to depended bugs.
: Votes should be distributed to depended bugs.
Status: VERIFIED WONTFIX
:
Product: Bugzilla
Classification: Server Software
Component: Bugzilla-General (show other bugs)
: unspecified
: All All
: P3 normal with 2 votes (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: default-qa
Mentors:
: 92440 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-11 23:27 PDT by Matthew Tuck [:CodeMachine]
Modified: 2012-12-18 20:46 PST (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Matthew Tuck [:CodeMachine] 1999-10-11 23:27:31 PDT
I suggest that any votes for a bug x that depends on bug y should get added to
bug y.  This is because without doing this, votes could give an uneven picture
of how important something is to get fixed.  Of course this means that one vote
could result in many votes being added to.  I suggest some way of preventing
voting on tracking bugs.

This compound figure is what should appear on queries, and on the bug report
itself, you should see:

Votes 15 (10 from Bug #1, 2 from Bug #2, 3 from this bug)
Comment 1 Terry Weissman 1999-10-12 03:52:59 PDT
Down this path leads nightmares.

People can track dependencies and decide for themselves where their votes go.
There's no way the machine is going to get it right, especially given all the
weird ways people are using the dependencies feature.
Comment 2 Matthew Tuck [:CodeMachine] 1999-10-12 05:16:59 PDT
I don't necessarily agree.

Machine computation is the main issue as I see it.  What this essentially means
is that you might need to update lots of bugs when you change a vote, since
computation at the time is probably too expensive.  I don't see how it can fail
to get it right.

I'm not sure what "strange" ways of using dependencies means.  If tracking bugs,
that's certainly an issue, and I'm sure sure how to prevent votes on general
bugs.  Perhaps votes should be split up down paths of multiple dependencies, and
you not be permitted to vote if there are too many.  If you are referring to
people stuffing up dependencies, I think these should be fixed on their own.

Your issues are certainly valid though, and they will need a resolution for this
to be implemented.
Comment 3 Johan Walles 2001-03-03 06:58:27 PST
Why has this bug been closed after so little discussion?  I think this would be
an excellent feature and have therefore added my vote to it even though it has
been "resolved".

Terry Weissman's comment that people should do this manually doesn't strike me
as very well founded.  Isn't the point of Bugzilla to make it easier for people
to handle bug reports?  And the point of the votes to make it easier for
developers to see where people are having problems?  If I vote for a bug that
needs for some other bug to get fixed, of course I want to see all the
dependencies fixed.

Terry, I'd appreciate very much if you could elaborate on the nightmares, what
you think would prevent the machine from getting it right, and the weird ways
people are using the dependencies feature.

Thanks!
Comment 4 Terry Weissman 2001-03-06 22:15:29 PST
See, for example, bug 70090.  Better yet, see the dependency tree, at
http://bugzilla.mozilla.org/showdependencytree.cgi?id=70090.

You can hand-wave around "some way of preventing voting on tracking bugs", but
it's going to be hard.

Here's an obvious abuse: someone who wants to vote on 17 different bugs can
create a new bug which depends on those 17, and then vote on it.

Yes, you could invent mechanisms to prevent and worry about all of these.  But
it's going to be complicated and hard-to-understand, and one of the
(ever-eroding) principles of Bugzilla is to try and keep things simple.  I
continue to believe that the complexity isn't worth it.
Comment 5 Matthew Tuck [:CodeMachine] 2001-04-16 05:15:17 PDT
I have to agree with Terry now on the proposal as it is outlined.  That's not to
say we can't do anything about it, however.  For example we might just say on
the bug report that one or more bugs blocked by this one has a vote.  Or maybe
it would be OK to show the number of votes on these.  But I think it's wrong to
add them onto this bug as the total would appear to a query.

However if you have any other proposals, please open a new bug report.

V.
Comment 6 Dave Miller [:justdave] (justdave@bugzilla.org) 2001-09-15 01:24:13 PDT
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Comment 7 Frédéric Buclin 2005-09-14 09:26:59 PDT
*** Bug 92440 has been marked as a duplicate of this bug. ***
Comment 8 Cees T. 2005-10-03 14:20:29 PDT
Bug 92440 is the new report mentioned in comment 5. It suggests a new field in
the database. That way, everybody wins.
Comment 9 Cees T. 2006-02-16 12:35:29 PST
(In reply to comment #4)

Users now have 1000 votes, so i think the vote abuse point is moot.

As for that dependency tree, it's only 4 levels deep. Have so many new users joined that modern day servers can't deal with updating a few extra fields?

Note You need to log in before you can comment on or make changes to this bug.