Closed Bug 1615483 Opened 6 months ago Closed 6 months ago

hide VR devices when privacy.resistFingerprinting = true

Categories

(Core :: WebVR, enhancement)

75 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1579243

People

(Reporter: simon.mainey, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fingerprinting])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Similar to Bug 1337161 where navigator.getGamepads() returns an empty array, we should do the same for virtual reality devices

Note: https://bugzilla.mozilla.org/show_bug.cgi?id=1603825#c2
There is also a FPing concern with the VR prompt

Component: Untriaged → WebVR
Product: Firefox → Core

In Bug 1579243, we present a potential solution for resisting fingerprinting. Essentially, the permission prompt will always appear when VR device access is requested by a site, regardless of the presence of the VR hardware.

This would ensure that a site can not infer the presence of such hardware unless the user grants permission to access it explicitly.

Would this bug be a duplicate of Bug 1579243, where this solution has already been explored?

Flags: needinfo?(simon.mainey)

(In reply to :kip (Kearwood Gilbert) from comment #1)

Would this bug be a duplicate of Bug 1579243, where this solution has already been explored?

I'm not knowledgeable enough on VR to fully know - but sure, I think all concerns can be handled under bug 1579243 . I'll post anything relevant there.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Flags: needinfo?(simon.mainey)
Resolution: --- → DUPLICATE
Duplicate of bug: 1579243
You need to log in before you can comment on or make changes to this bug.