border collapse property may only be set once

VERIFIED WORKSFORME

Status

Core Graveyard
GFX
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Will Holcomb, Assigned: Kevin McCluskey (gone))

Tracking

({testcase})

Trunk
x86
Windows NT
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
This piece of javascript will only work if the table is initially set to
collapse and then it will only work once.

function toggleBorderCollapse() {
  var table = document.getElementsByTagName("table")[0];
  table.style.borderCollapse =
    table.style.borderCollapse == "separate" ? "collapse" : "separate";
  window.status = "Set border collapse to: " + table.style.borderCollapse;
}

Comment 1

16 years ago
WFM using build 20020806, Windows 98 SE.

Comment 2

16 years ago
could you provide a testcase with html as an attachment, please?

Comment 3

16 years ago
Look at the URL.

WFM, 2002-08-06-14 trunk Linux.
This was a problem a while back, but has been fixed for a number of months now...

Will, please reopen if you are seeing this with a current (1.1beta) build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
Created attachment 94461 [details]
A document with a script of the sort described in the initial report

This was intially a bug test for the border-collapse property, but the
javascript to test didn't work correctly, and it became a bug report on setting
the borderCollapse style rule.
(Reporter)

Comment 6

16 years ago
I am reporting this from mozilla 1.1b 2002072104
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Hmm...  I don't think anything really major has changed in this area since
1.1beta, but I can't reproduce this....
From some mails:

Will (paraphrased):

"In a current build it almost works.  I see some flickering, but it does not
paint the border."

Me:

I did some testing and I see the problem in your bug report with build
2002-07-23-08.  It works fine for me with build 2002-07-23-21.  Looks
like bug 158230 may have been responsible for fixing this... (at least
to the point where the problem is now a painting one).
Assignee: jst → kmcclusk
Component: DOM Style → GFX Compositor
QA Contact: ian → petersen

Comment 9

16 years ago
The missing border is already reported in bug 161566 (assigned to HTMLTables).
So, is this bug about the "flickering"?
Keywords: testcase
(Reporter)

Comment 10

16 years ago
This bug is about the borderCollapse style being set and only changing the first
time that it is set. The expected behavior is for each click to toggle the style
and for the table back and forth. (Well, each click does toggle the style, the
expected behavior is for each change of the style to cause the page to be
displayed with that appearance.)

It has been reported that in linux this happens. In NT and 2000 when I click it
changes the first time, but after that only flickers a bit. The table does not
change.

Why noone else seems to experience this is beyond me. I can't imagine I am
clicking poorly. =)
Thanks for the info Will, but if you read the comments we think this has been
fixed already (Boris tracked it down to 2002-07-23). Your build is older.
Since this part of the bug is "WORKSFORME" I was wondering if there were other
problems that would justify this bug still being open.
Will, could you download the latest build from 
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/
and see if this solves the problems reported in this bug? Thanks.
(Reporter)

Comment 13

16 years ago
The nightly build fixes it
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
OK, thanks.

Verified wfm.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.