Open Bug 1616125 Opened 3 years ago Updated 3 years ago

Images duplicated in Reader View for all New York Times articles because we keep `visibility: hidden` images in the DOM and strip the styles

Categories

(Toolkit :: Reader Mode, defect, P3)

73 Branch
defect

Tracking

()

REOPENED

People

(Reporter: punnamvarun, Unassigned)

References

()

Details

(Whiteboard: [reader-mode-readability-algorithm])

Attachments

(2 files)

Attached image firefox bug.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

  1. Open any New York Times article that begins with an image
  2. Enter Reader View

Actual results:

Once in Reader View, one is presented with the opening image displayed twice, one right above the other. Attached is an image displayed one such duplication on the article "Pier 1 Imports Files for Bankruptcy and Seeks a Buyer."

Expected results:

Reader view should have displayed the initial image only once

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

Looks like the NYT have some kind of lazy-loading setup that uses visibility:hidden to hide the image and then clone it to another node, or something like that (either way, they end up with 2 images in the DOM), and readability doesn't strip the hidden one, leading to 2 visible images in reader mode.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Summary: Images Duplicate in Reader View for all New York Times articles → Images duplicated in Reader View for all New York Times articles because we keep `visibility: hidden` images in the DOM and strip the styles
Whiteboard: [reader-mode-readability-algorithm]

On nightlies with the changes from bug 1618969, this appears to be fixed. \o/

Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1618969
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

For reference, I couldn't reproduce the issue with every article; https://www.nytimes.com/2020/02/17/business/pier1-bankruptcy.html seems to be broken on beta and working on current nightly though, so I hope/assume that means it's fixed.

Flags: qe-verify+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
No longer depends on: 1618969
Target Milestone: mozilla75 → ---
You need to log in before you can comment on or make changes to this bug.