Closed Bug 1616164 Opened 4 years ago Closed 10 months ago

Anchor jumping doesn't work when going back/forward

Categories

(Core :: Disability Access APIs, defect, P2)

defect

Tracking

()

VERIFIED FIXED
116 Branch
Tracking Status
firefox-esr102 --- wontfix
firefox-esr115 --- wontfix
firefox114 --- wontfix
firefox115 --- wontfix
firefox116 --- verified

People

(Reporter: Jamie, Assigned: nlapre)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached file Test case.

Note that in the below STR, NVDA may say "visited link" instead of "link" depending on whether this is the first time through the STR.
STR (with the NVDA screen reader):

  1. Open the attached test case.
  2. Press control+home. NVDA will say "link Section 1".
  3. Press enter.
    • Observe: NVDA says "heading level 1 Section 1"
  4. Press control+home. NVDA will say "visited link Section 1".
  5. Press down arrow. NVDA will say "link Section 2".
  6. Press enter.
    • Observe: NVDA says "heading level 1 Section 2"
  7. Press alt+leftArrow to go back.
    • Expected: NVDA should say "heading level 1 Section 1"
    • Actual: Nothing.
  8. Press alt+rightArrow to go forward.
    • Expected: NVDA should say "heading level 1 Section 2"
    • Actual: Nothing.

This occurs because we only fire scrollingStart events when focus is fired on the document. In this case, the document is already focused when you go back or forward, so there's no focus change to trigger the scrollingStart.

Tying of scrollingStart events to focus events happened in bug 691734. Before that point, I'm pretty sure this would have worked. We still need to ensure scrollingStart happens after initial document focus, though.

Has Regression Range: --- → yes
See Also: → 1789235
Severity: normal → S3
Assignee: nobody → nlapre

Closing this as fixed, addressed by revision D177419.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Depends on: 1789235
See Also: 1789235
Target Milestone: --- → 116 Branch
Flags: qe-verify+

I've reproduced this issue using Nightly 7115.0a1 (2023-05-31) following the STR from Comment 0 on Windows 10 x64 with NVDA enabled.
Verified as fixed on the latest Firefox 116.0 under same configuration: NVDA reads out load "heading level 1 Section 1"(when pressing alt+leftArrow ) and "heading level 1 Section 2"(when pressing alt+rightArrow )

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: