Closed Bug 1616544 Opened 2 years ago Closed 2 years ago

Permafailing dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface CSSPseudoElement to all webpage.. when Gecko 75 merges to Beta on 2020-03-09

Categories

(Core :: DOM: Animation, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla75
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- unaffected
firefox75 + verified

People

(Reporter: aciure, Assigned: boris)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Central as beta: https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=289512403&resultStatus=pending%2Crunning%2Csuccess%2Ctestfailed%2Cbusted%2Cexception%2Cusercancel%2Crunnable&revision=44732bf48e0a378e385078f10ab708e48faf384d&searchStr=Linux%2C18.04%2Cx64%2Cdebug%2CMochitests%2Ctest-linux1804-64%2Fdebug-mochitest-e10s-10%2CM%2810%29

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=289513442&repo=try&lineNumber=6866

[task 2020-02-19T12:17:19.863Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | MimeTypeArray is exposed as an own property on the window but has no property descriptor in the global scope
[task 2020-02-19T12:17:19.864Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface CanvasCaptureMediaStream to all webpages as a property on the window? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-02-19T12:17:19.864Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | CanvasCaptureMediaStream is exposed as an own property on the window but tests false for "in" in the global scope
[task 2020-02-19T12:17:19.864Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | CanvasCaptureMediaStream is exposed as an own property on the window but has no property descriptor in the global scope
[task 2020-02-19T12:17:19.865Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface MediaStreamAudioSourceNode to all webpages as a property on the window? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-02-19T12:17:19.866Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | MediaStreamAudioSourceNode is exposed as an own property on the window but tests false for "in" in the global scope
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | MediaStreamAudioSourceNode is exposed as an own property on the window but has no property descriptor in the global scope
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface HTMLDataElement to all webpages as a property on the window? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | HTMLDataElement is exposed as an own property on the window but tests false for "in" in the global scope
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | HTMLDataElement is exposed as an own property on the window but has no property descriptor in the global scope
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - Buffered messages finished
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface CSSPseudoElement to all webpages as a property on the window? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:299:16
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - runTest@dom/tests/mochitest/general/test_interfaces.js:1467:7
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - @dom/tests/mochitest/general/test_interfaces.js:1506:1
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | CSSPseudoElement is exposed as an own property on the window but tests false for "in" in the global scope
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | CSSPseudoElement is exposed as an own property on the window but has no property descriptor in the global scope
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface Request to all webpages as a property on the window? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-02-19T12:17:19.883Z] 12:17:19 INFO - TEST-PASS | dom/tests/mochitest/general/test_interfaces.html | Request is exposed as an own property on the window but tests false for "in" in the global scope

Summary: TEST-UNEXPECTED-FAIL | dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface CSSPseudoElement to all webpage.. when Gecko 75 merges to Beta on 2020-03-09 → Permafailing dom/tests/mochitest/general/test_interfaces.html | If this is failing: DANGER, are you sure you want to expose the new interface CSSPseudoElement to all webpage.. when Gecko 75 merges to Beta on 2020-03-09
Flags: needinfo?(boris.chiou)

[Tracking Requested - why for this release]:

Assignee: nobody → boris.chiou
Flags: needinfo?(boris.chiou)

We test this only in wpt, and test_interfaces.js should treat
it as a disabled interface because its preference is default off on all
channels.

Pushed by bchiou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0f9256bb4a51
Mark CSSPseudoElement as a disabled interface. r=smaug
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
You need to log in before you can comment on or make changes to this bug.