Closed Bug 1617050 Opened 6 months ago Closed 4 months ago

Drop shadows are rendered incorrectly if content is partially clipped

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: cbrewster, Assigned: nical)

References

Details

Attachments

(3 files)

Attached file test-case

If the original content is clipped for some reason, the drop-shadow for it is not rendered correctly.

The priority flag is not set for this bug.
:jbonisteel, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jbonisteel)
Blocks: wr-76
Flags: needinfo?(jbonisteel)
Priority: -- → P3

Connor - do you think this is a regression? If so, can you find a regression window?

I don't believe this is a regression, I tested with WR from ~2 years ago and it has the same issue.

We probably need to do something along the lines of the todo here: https://searchfox.org/mozilla-central/rev/278046367dab878316f60f0bd7f740cf73f3c447/gfx/wr/webrender/src/picture.rs#4683-4684

See Also: → 1623711
Flags: needinfo?(nical.bugzilla)

Nical, do you have a feeling about how to fix this?

We probably need to do something along the lines of the todo here: https://searchfox.org/mozilla-central/rev/278046367dab878316f60f0bd7f740cf73f3c447/gfx/wr/webrender/src/picture.rs#4683-4684

I think that Connor's suggestion makes sense. The reason this was left as a TODO and not just fixed along with whatever the comment came with probably is that there was some trickiness involved but I don't remember very well. I'll have a look when we are confident with the work blocking shipping more intel GPUs.

Flags: needinfo?(nical.bugzilla)
Assignee: nobody → nical.bugzilla

Depends on D68230

Duplicate of this bug: 1623711
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/da4563936652
Take shadow offsets into account when clipping a primitive. r=gw
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Regressions: 1626827
Regressions: 1626209
Regressions: 1640523
You need to log in before you can comment on or make changes to this bug.