Closed Bug 1617156 Opened 1 month ago Closed 1 month ago

Store snapped reference frame offset in prim rect to minimize quantization effects

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

We currently pass in the snapped reference frame relative offset in the integer parameters of the prim header to the shader. We don't actually use the prim rect size for anything, so we could just stuff that offset there and avoid any quantization effects caused by us casting the float to an integer.

Blocks: wr-75

Currently we quantize the snapped reference frame relative offset used
in the shader in order to stuff it in our extra integer parameter fields
in the prim header. Since we don't use the prim rect size for anything
in the text shader, this patch just puts it there instead, and avoids
quantizing that.

Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26d8dfb033ce
Store snapped reference frame offset in prim rect for text to avoid quantization effects. r=lsalzman
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
You need to log in before you can comment on or make changes to this bug.