Closed Bug 1617311 Opened 1 year ago Closed 1 year ago

Details element and state are not spoken in VoiceOver

Categories

(Core :: Disability Access APIs, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla76
Tracking Status
firefox76 --- verified
firefox77 --- verified

People

(Reporter: eeejay, Assigned: morgan)

References

(Blocks 1 open bug)

Details

(Whiteboard: [mac2020_1])

Attachments

(1 file)

With the given url:
data:text/html,<details><summary>Foo</summary><p>Bar</p></details>

Firefox announces "Foo" as a text element.

Safari announces it as "collapsed summary", and when it is expanded it says "expanded summary"

Chrome calls it a "disclosure triangle" which seems more akin to native controls

Blocks: 1617312
No longer blocks: 1617312
Summary: Fieldsets not announced as groupings in VoiceOver → Details element and state are not spoken in VoiceOver
Assignee: nobody → mreschenberg
Priority: P2 → P1
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/770bab6f22e9
Add details/summary attributes and values. r=eeejay
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Flags: qe-verify+

Successfully reproduced the issue on Firefox Nightly 75.0a1 (2020-02-22) under macOS 10.15 using the URL provided in Comment 0.

The issue is fixed on Firefox Nightly 77.0a1 (2020-04-16) and Firefox 76.0b5 under macOS 10.15.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.