This page's links, loading, and scrolling respond very slowly

RESOLVED DUPLICATE of bug 120893

Status

()

--
major
RESOLVED DUPLICATE of bug 120893
17 years ago
16 years ago

People

(Reporter: darkelipse55, Assigned: jst)

Tracking

({perf})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020730
BuildID:    2002073008

For some reason Mozilla responds very slowley when on www.stenterprise.com
anything you try to do there takes very long for a reaction when clicking on a
link or scrolling just visit the page and you will see.

Reproducible: Always
Steps to Reproduce:
1.Go to www.stenterprise.com
2.Try scrolling
3.Or click on a link to see the responce.

Actual Results:  Everything reacts very very slowley making it almost unusable.

Expected Results:  For the page to respond normally and scrolling not to take ages.

Comment 1

17 years ago
WFM Linux 1.1b
very fast for me (1 day old win32 build)

-> GFX
Assignee: sgehani → kmcclusk
Severity: blocker → major
Component: XP Apps → GFX Compositor
QA Contact: paw → petersen
(Reporter)

Comment 3

17 years ago
I'll update my build tonight and try again, I also found it very slow with
Internet Explorer and Netscape 7, but Chimera loads and responds faster but not
by much.... Could this possibly be because of a low speed machine? If so this is
the only website that responds like this.

Comment 4

17 years ago
Confirmed using FizzillaCFM/2002080508. The page took 16 seconds to load, and
mouse wheel scrolling is abysmally slow, though dragging the elevator results in
faster scrolling.

Fizzilla's performance has been craptacular in general for several days now. See
also bug 161481, comments 10 and 11.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
Summary: This page responds very very slowley with links/loading/and scrolling → This page's links, loading, and scrolling respond very slowly

Comment 5

17 years ago
Ack, this page locked up Mozilla for longer than I was willing to wait (on OS
X). It's dreadful.

Comment 6

17 years ago
Fascinating, Jim.

I think this may be pilot error (i.e., the author is doing something bogus). 
[I need to check this again, since this JS is written with no whitespace or 
linefeeds].

The problem is see is specifically:


window.onscroll = SetupToolbar;
function SetupToolbar() {
    // do a whole bunch of stuff, including get and set positions
    // which can result in reflows...
    // ... and then queue this function up again:
    if (/* test: is this mozilla/5.0? */) {
        window.setTimeout(SetupToolbar, 100);
    }
}


So any scroll event triggers an infinite series of expensive operations on the 
document, launching (at least) every 100msec.

However, I don't think we should invalid this yet, since I also noticed that
on win2k (and presumably other OS) we go through the roof on the heap during 
the page (i.e., I was seeing VM Size grow by 50MB, and then shrink back down
as the page loaded).

At any rate the perf issues seem all related to the DHTML menu in that page. If 
I remove that from a mirror copy of the page, I load the page in about a third 
of the current loadtime and scrolling speed is acceptable. [Note: I dispute the 
previous assessment that this is "very fast" on win32. It's not. At all].

-> DOM, at least for now.
Assignee: kmcclusk → jst
Component: GFX Compositor → DOM Level 0
QA Contact: petersen → desale

Updated

17 years ago
No longer depends on: 161481

Comment 7

17 years ago
Note that the page is horrifically invalid and unwell-formed, with massive table
errors.

Comment 8

17 years ago
> horrifically invalid and unwell-formed, with massive table errors

So, in other words, it looks like a typical real=world web page? Is that what
you are pointing out?

Comment 9

16 years ago

*** This bug has been marked as a duplicate of 120893 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.