Closed Bug 161791 Opened 18 years ago Closed 10 years ago

Save As dialog of mail compose window can't handle non-ASCII filename

Categories

(MailNews Core :: Internationalization, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.1b2

People

(Reporter: kazhik, Assigned: m_kato)

References

Details

Attachments

(2 files, 3 obsolete files)

Save As dialog of mail compose window can't handle non-ASCII
filename.

(1) Open a mail compose window.
(2) Select [File]-[Save As]-[File], enter a non-ASCII filename
 and save it.
(3) Select [File]-[Save As]-[File] again.

Actual result: Filename is displayed in escaped string.

Expected result: Filename is displayed as it was entered.

Build: 2002080808-trunk/Linux

Original report in Bugzilla-jp:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2505
dup of 155659?
i meant to say bug # 155569.
> (2) Select [File]-[Save As]-[File], enter a non-ASCII filename
>  and save it.
> (3) Select [File]-[Save As]-[File] again.

For both 2 and 3, I see the default string "message.eml" as a file name.
Koike san, could you attach a screen shot of the problem?
Status: NEW → ASSIGNED
Attached image Screenshot
(1) Enter <kanji> and save it.
(2) Open "Save As" dialog again.
I can reproduce it, thanks.
Attached patch simple fix (obsolete) — Splinter Review
bug 168788 looks similar.
Attachment #138878 - Attachment is obsolete: true
Product: MailNews → Core
Product: Core → MailNews Core
QA Contact: marina → i18n
Reproduce on 3.1 (20100405)
Assignee: nhottanscp → nobody
Status: ASSIGNED → NEW
OS: Linux → All
Hardware: x86 → All
Attached patch patch (obsolete) — Splinter Review
Attachment #437270 - Flags: review?(neil)
Assignee: nobody → m_kato
Comment on attachment 437270 [details] [diff] [review]
patch

Unfortunately there is a minor regression when using SeaMonkey Composer to edit pages containing certain special characters, for example if you edit http://en.wikipedia.org/wiki/%5C on Windows and then try to Save As the suggested filename is \.html rather than, say, _.html which would have been suggested had you created a new page with a title of \.
Attached patch patch v2 (obsolete) — Splinter Review
Attachment #437270 - Attachment is obsolete: true
Attachment #437270 - Flags: review?(neil)
Comment on attachment 437528 [details] [diff] [review]
patch v2

unescape on file:// only
Attachment #437528 - Flags: review?(neil)
That's a shame because I liked the way the original fixed up the suggested file name of other Wikipedia pages...
That's a shame because I liked the way the original patch fixed up the suggested file name of other Wikipedia pages...
(In reply to comment #13)
> That's a shame because I liked the way the original patch fixed up the
> suggested file name of other Wikipedia pages...

Neil, Is there a interface or method to generate normalized file name from string?
GetSuggestedFileName already calls GenerateValidFilename to clean up the page title to use as a file name, but that function is deprecated and you should try to use the validateFileName function if you can.
Thank you, neil.  I will try it.
Attached patch patch v3Splinter Review
Attachment #437528 - Attachment is obsolete: true
Attachment #437528 - Flags: review?(neil)
Comment on attachment 437776 [details] [diff] [review]
patch v3

No wonder GenerateValidFilename is deprecated; validateFileName looks so much nicer to use :-)
Attachment #437776 - Flags: review+
landed
http://hg.mozilla.org/comm-central/rev/9a96ffdd6081
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1b2
Duplicate of this bug: 168788
You need to log in before you can comment on or make changes to this bug.