Closed Bug 1618700 Opened 5 years ago Closed 4 years ago

Selected aria tab is not indicated in VoiceOver or announced when selected.

Categories

(Core :: Disability Access APIs, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla76
Tracking Status
firefox76 --- verified

People

(Reporter: eeejay, Assigned: eeejay)

Details

(Whiteboard: [mac2020_1])

Attachments

(1 file)

STR:

  1. Load https://mdn.mozillademos.org/en-US/docs/Web/Accessibility/ARIA/Roles/Tab_Role$samples/Example
  2. Navigate to second tab and activate it.

Expected:
Safari says "press Second Tab, selected, tab, 2 of 3"

Actual:
Firefox says "Switch Second Tab, tab"

Three things to note:

  • Firefox identifies the tab group correctly
  • The selected state and selection action are not announced
  • The position of the tabs in the group is not announced (ie "2 of 3").
Priority: -- → P2
Assignee: nobody → eitan

I made more generalized mozSelectableAccessible and
mozSelectableChildAccessible classes for other things that will need
this kind of support.

Priority: P2 → P1
Status: NEW → ASSIGNED
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/70fee75ec91e
Implement expected attributes and events for tabs. r=morgan
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Flags: qe-verify+

I could reproduce the initial issue using old Nightly build (2020-02-27) on macOS 10.15.4. Using latest beta build 76.0b4 the tabs are announced with the message "Second Tab, tab, 2 of 3", the announcement that this is the selected tab will not be there only if I click the tab first then the message will change to "Second Tab, selected, tab, 2 of 3". Also I can see that voiceover does not announce when I switch tabs using mouse cursor but only with the Tab key and arrow keys.
Should we log a bug on this behaviour? I noticed that Safari behaves the same as Firefox, but Chrome does not, I can use the mouse cursor to switch between tabs and those are announced by voiceover as selected tabs.

Flags: needinfo?(eitan)

What you are seeing is the expected behavior. In the STR I might have missed a step where the second tab is the selected one.

Also, using a mouse cursor will not work in the above example because they use tabindex=-1 so focus is not received via mouse and thus the VO cursor will not move.

Flags: needinfo?(eitan)

(In reply to Eitan Isaacson [:eeejay] from comment #5)

What you are seeing is the expected behavior. In the STR I might have missed a step where the second tab is the selected one.

Also, using a mouse cursor will not work in the above example because they use tabindex=-1 so focus is not received via mouse and thus the VO cursor will not move.

Thanks for the info Eitan, marking as verified fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: