Closed Bug 1618914 Opened 3 years ago Closed 1 year ago

MOZ_ENABLE_WAYLAND=1 crashes due to posix_fallocate failures

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

RESOLVED FIXED
96 Branch
Tracking Status
firefox-esr91 --- fixed
firefox75 --- wontfix
firefox94 --- wontfix
firefox95 --- wontfix
firefox96 --- fixed

People

(Reporter: jbeich, Assigned: rmader)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

Attached patch v1 (obsolete) — Splinter Review
Depends on: 1640094
Attached patch v2 (obsolete) — Splinter Review

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8001a280e1c01e0983f74606edd5224b5025c9e9

Handle EINVAL and EOPNOTSUPP in WaylandShmPool::Resize as well.

Attachment #9129826 - Attachment is obsolete: true

Please use phabricator for it and mark me for review there.
Thanks.

Priority: -- → P3

I can't as explained in bug 1536716.

Attached patch v3 (obsolete) — Splinter Review

https://treeherder.mozilla.org/#/jobs?repo=try&revision=0c73e14dba7bb859429b576947f7c150acd1d673

After bug 1619882 posix_fallocate is now called after shm_open (non-filesystem object) which is not supported by FreeBSD < 13. Let's ignore ENODEV as well.
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247329#c3

Attachment #9155728 - Attachment is obsolete: true
Regressed by: 1619882
Summary: MOZ_ENABLE_WAYLAND=1 crashes when XDG_RUNTIME_DIR is on ZFS → MOZ_ENABLE_WAYLAND=1 crashes due to posix_fallocate failures
Has Regression Range: --- → yes
Attached patch v4Splinter Review

Rebased after bug 1711094.

Attachment #9159357 - Attachment is obsolete: true
Assignee: nobody → robert.mader
Status: NEW → ASSIGNED

Thanks for the patch and sorry it took so long @Jan!

Pushed by robert.mader@posteo.de:
https://hg.mozilla.org/integration/autoland/rev/ca4e0f9642ed
Fall back to ftruncate if posix_fallocate isn't supported by filesystem, r=stransky
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Do we need this on ESR?

Flags: needinfo?(robert.mader)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #11)

Do we need this on ESR?

Nice to have - i.e. if it applies cleanly.

Flags: needinfo?(robert.mader)

It does. Feel free to nominate :)

Comment on attachment 9253047 [details]
Bug 1618914 - Fall back to ftruncate if posix_fallocate isn't supported by filesystem, r=stransky

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Fixes crashes in the (non-default) Wayland backend on some setups.
  • User impact if declined: see above
  • Fix Landed on Version: 96
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Code is simple and add a additional fallback for an unlikely case.
  • String or UUID changes made by this patch:
Attachment #9253047 - Flags: approval-mozilla-esr91?

Comment on attachment 9253047 [details]
Bug 1618914 - Fall back to ftruncate if posix_fallocate isn't supported by filesystem, r=stransky

Approved for 91.5esr.

Attachment #9253047 - Flags: approval-mozilla-esr91? → approval-mozilla-esr91+
You need to log in before you can comment on or make changes to this bug.