Closed Bug 1619149 Opened 29 days ago Closed 21 days ago

Missing sort arrows in column headers of the SeaMonkey Modern theme

Categories

(SeaMonkey :: Themes, defect)

Desktop
All
defect
Not set

Tracking

(seamonkey2.53 affected, seamonkey2.57esr affected)

RESOLVED FIXED
seamonkey 2.72
Tracking Status
seamonkey2.53 --- affected
seamonkey2.57esr --- affected

People

(Reporter: ant, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53.1

Steps to reproduce:

  1. In my decade old, updated 64-bit W7 HPE SP1 and Linux (Debian Jessie v8) PCs, opened up my upgraded SeaMonkeys (official seamonkey-2.53.1.en-US.win64.installer.exe and seamonkey-2.53.1.en-US.linux-x86_64.tar.bz2).
  2. Opened up Library, Mail and Newsgroups, Addresbooks, etc. that let you sort their columns.
  3. Click on a column to sort.

Other users see this too in my news.mozilla.org's mozilla.support.seamonkey "Did SM v2.53.1 remove its column sort arrows?" newsgroup thread.

Actual results:

Missing arrows shown even though correctly sorted.

Expected results:

2.49.5 and earlier versions used to show the arrows when clicking on columns.

NOT reproducible with installation of unofficial (by wg9s) De SeaMonkey 2.53.2 beta 1 pre Mozilla/5.0 (NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 Build 20200222130008 (Default Classic Theme, newly created User Profile) on German WIN7 64bit

OS: Unspecified → Windows 10
Summary: Missing sort arrows in columns. → Missing sort arrows in column headers

OK. I figured out what was causing it. "SeaMonkey Modern" theme even in a new profile. Default showed the arrows just fine. I'll update my bug report about this. Also, I reproduced this with https://archive.mozilla.org/pub/seamonkey/releases/2.53.1/mac/en-US/seamonkey-2.53.1.en-US.mac.dmg in updated mac OS Mojave v10.14.6. So, this is a theme issue.

(In reply to Ant from comment #2)

OK. I figured out what was causing it. "SeaMonkey Modern" theme even in a new profile. Default showed the arrows just fine. I'll update my bug report about this. Also, I reproduced this with https://archive.mozilla.org/pub/seamonkey/releases/2.53.1/mac/en-US/seamonkey-2.53.1.en-US.mac.dmg in updated mac OS Mojave v10.14.6. So, this is a theme issue.

I just tested with the Modern theme and I also don't see an arrow in the Folder or Thread panes column headers, but do see them using the default theme.

Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53.1

Status: UNCONFIRMED → NEW
Component: General → Themes
Ever confirmed: true
OS: Windows 10 → All
Hardware: Unspecified → Desktop
Summary: Missing sort arrows in column headers → Missing sort arrows in column headers of the SeaMonkey Modern theme
Attached patch Port changes from Bug 780562 (obsolete) — Splinter Review

This ports the changes to global-platform from Bug 780562
Seems to fix it on linux

Assignee: nobody → iann_bugzilla
Attachment #9130475 - Attachment is obsolete: true
Attachment #9130477 - Flags: feedback?(frgrahl)
Status: NEW → ASSIGNED
Comment on attachment 9130477 [details] [diff] [review]
Port changes from Bug 780562 (fixed jar formatting)

LGTM r/a+ set for Bill
Attachment #9130477 - Flags: review+
Attachment #9130477 - Flags: feedback?(frgrahl)
Attachment #9130477 - Flags: approval-comm-release+
Attachment #9130477 - Flags: approval-comm-esr60+
Duplicate of this bug: 1620759

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/162a48c7ff4c
Missing sort arrows in column headers of the SeaMonkey Modern theme. r=WG9s DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 21 days ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.72
Version: SeaMonkey 2.53 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.