Closed Bug 1619821 Opened 8 months ago Closed 8 months ago

Turn on dom.animations-api.getAnimations.enabled in release channels

Categories

(Core :: DOM: Animation, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: birtles, Assigned: birtles)

References

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

I think that after bug 1619516 is fixed and I get a few more spec edits in we should be ready to turn this on by default.

Boris, does bug 1615083 need to block this?

Flags: needinfo?(boris.chiou)

OK. I just write a test (https://jsfiddle.net/borischiou/wgsbpujr/):

target::before {
  margin-left: 10px;
}
<div id='target'></div>
const d = document.getElementById('target');

const effect = new KeyframeEffect(null, {opacity:['0.5', '1']}, 10000);
const anim = new Animation(effect, document.timeline);
anim.play();
effect.target = d;
effect.pseudoElement = '::before';

console.log(d.getAnimations({subtree: true}));
console.log(document.getAnimations());

I got one animation from both.

Sorry, it seems document.getAnimations() and element.getAnimations() work well by my test. So comment 1 and comment 2 are not the issue. Perhaps bug 1615083 shouldn't block this I think.

Can this wait until next week so it rides to 76? We're trying to avoid pref changes in the last few days of a nightly cycle.

(In reply to Julien Cristau [:jcristau] from comment #5)

Can this wait until next week so it rides to 76? We're trying to avoid pref changes in the last few days of a nightly cycle.

I'm afraid we're targeting 75 for this in order to synchronize with Apple and Google's release plans.

This also removes the comment about CSSPseudoElement since that is now covered by a
separate pref: dom.css_pseudo_element.enabled.

Assignee: nobody → brian
Status: NEW → ASSIGNED

I'm pretty sure Safari is shipping CSSTransition and CSSAnimation to non secure contexts but let me check...

Confirmed that Safari Tech Preview 102 exposes these in non-secure contexts.

Pushed by bbirtles.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4a0d1e903112
Turn on dom.animations-api.getAnimations.enabled unconditionally; r=smaug
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
You need to log in before you can comment on or make changes to this bug.