Closed Bug 1620180 Opened 3 years ago Closed 3 years ago

[Wayland] Dragging tabs often causes Gnome Shell to crash

Categories

(Core :: Widget: Gtk, defect)

74 Branch
Unspecified
Linux
defect
Not set
normal

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected

People

(Reporter: ke5trel, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Attachments

(1 file)

Attached file wayland-dnd-log.txt

STR:

  1. Start with env GDK_BACKEND=wayland on Ubuntu 19.10 (GNOME Shell 3.34.1).
  2. Restore a previous session.
  3. When the active tab is still loading, quickly drag a different tab horizontally (don't need to leave tab strip).

Gnome Shell will immediately crash when the tab starts being dragged. It is fairly easy to reproduce but if it doesn't happen, quit browser and try again.

It also happens when tab dragging is initiated at other times but this is the most reliable way I have found to reproduce it.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fe29ec1ab8c391a81064d1b8d7d3c4bec41e2fb9&tochange=1b717628c7e944103524b4cd4d63ce3c1bc5694e

Regressed by Bug 1604048.

This is a known bug and apparently fixed for month. Please update GS to something more recent (we are at 3.34.4 now) or, more importantly, engage with you distribution to ship point releases faster.

Well, let's say weeks :)

Pascal: this is obviously not a FF but a GS bug (it should never crash, no matter what Firefox does). And it's fixed already (can't find the other bug right now, but the Ubuntu 19.10 Mutter version is known to have this bug - and they didn't update since december). So we can close this and hope Ubuntu gets faster in shipping updates...

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1622527

Ubuntu 19.10 just updated GS to 3.34.3 and the issue is no longer reproducible.

Status: RESOLVED → VERIFIED
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.