Closed Bug 1620797 Opened 3 years ago Closed 3 years ago

Firefox Narrator omits first word of paragraph when reading at high speed

Categories

(Toolkit :: Reader Mode, defect)

73 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: numajames, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

Go to a page with text, this one for example:
https://landing.google.com/sre/sre-book/chapters/service-level-objectives/
Toggle reader view
Click Narrate button
Set speed to maximum
Click play button
Listen for several paragraphs

Actual results:

The first word, or perhaps several hundred milliseconds, of each paragraphs are omitted from speech rendering.

Expected results:

All words in paragraph should be read.

OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

I can't reproduce on my win10 machine. The UA suggests you're seeing this on Windows 10, is that accurate? What voice are you using, and does the issue reproduce on a clean Firefox profile ( https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles ) ?

Flags: needinfo?(numajames)

Windows 10 is correct. Same behavior with Microsoft David, Hazel, and Zira. Reproduced the issue with a clean Firefox profile. To clarify, the first word of the first paragraph is read, but the first word of each subsequent paragraph is skipped.

Upon further investigation, I found the issue occurs when I'm listening with my Bluetooth headphones but it disappears (no skipping) when listening with my laptop's main speakers. I tried the narrator on Microsoft Edge browser and it worked the same way. Therefore, it looks like the root cause is something related to Bluetooth or my Bluetooth headphones.

This doesn't appear to be a Firefox issue so I'll close this ticket.

Flags: needinfo?(numajames)
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.