Closed Bug 1621574 Opened 1 year ago Closed 1 year ago

Addon Greasemonkey is not working since version 74.0 (today)

Categories

(WebExtensions :: Untriaged, defect)

74 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bfoss, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

I'm using the addon Grerasemonkey 4.9, yesterday it works, today after the update not.

Actual results:

The addon makes nothing

Expected results:

I expected that it will continue working.
The same happened on another Laptop, and also my son has the problems, but he's using other scripts than I.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Product: Firefox → WebExtensions

Could you please provide an example of a script that is not working?
I've Tried to reproduce this on Windows 10 pro 64-bit on FF 74.0 (20200309095159) but the script, https://greasyfork.org/en/scripts/5566-youtube-links for example, seems to be applied the same after updating the extension from 4.8 to 4.9.
Also if there were any particular steps you performed before or after update that would be helpful as well.
Thank you

Flags: needinfo?(bfoss)

Hi,

I am not able to replicate the issue. I've tried on: windows 10 pro

On the following versions:
Release 74.0 (64-bit)
Beta 75.0b11 (64-bit)
Firefox Nightly 76.0a1 (2020-03-31) (64-bit)

I installed this one https://addons.mozilla.org/es/firefox/addon/greasemonkey/, version 4.9, (last update 10 months ago) but it is working fine, what do you mean when you say addon does nothing? I also used Miruna's example https://greasyfork.org/es/scripts/5566-youtube-links and works, all other buttons from the greasemonkey menu are also working (editing scripts, importing/exporting, etc)

Any additional step or information will be appreciated, so I can replicate on my end.

Thanks for the report.

Best regards, Clara.

(In reply to Miruna Curtean from comment #2)

Created attachment 9137149 [details]
Greasy Monkey Youtube script is working after update.gif

Could you please provide an example of a script that is not working?
I've Tried to reproduce this on Windows 10 pro 64-bit on FF 74.0 (20200309095159) but the script, https://greasyfork.org/en/scripts/5566-youtube-links for example, seems to be applied the same after updating the extension from 4.8 to 4.9.
Also if there were any particular steps you performed before or after update that would be helpful as well.
Thank you

Sure, here is my programm:

function tryit(){
var a = 0;
}
var code = tryit.toString() + ";tryit();";
window.eval(code);

Mozilla says, that this function "tryit" is no function, with the earlier mozilla version, it will work!!!

best regards

Flags: needinfo?(bfoss)

Hello,
So far I did not see anything in particular happening in the browser console or in a new tab console on FF 73 using the Greasemonkey 4.9 and the userscript provided, so I am having trouble figuring out what is missing in the first place. Same for the other versions of Firefox: FF 75.0 (20200403170909), FF 76.0b1 (20200406152003) and FF 77.0a1 (20200406214750) on Windows pro 10 64-bit.
For more clarity, could you please respond to the following questions?

  1. On what site(s) is this function supposed to work? Or what url?
  2. What was the result of using the function before it stopped working?
  3. You mentioned that you receive a message, after update, from mozilla - that "tryit" is it not a function. Could you provide the exact message?
  4. Where do you see that message? Is it in the browser console (CTRL+SHIFT+J) or on a particular page console (F12)?

That would be all for now, thank you.

Flags: needinfo?(bfoss)

Hello,
today I've fixed the problem.

instead of using:

function tryit(){
var a = 0;
}
var code = tryit.toSource() + ";tryit();"; // <--------------- .toSource it not working since Firefox 74, why ??????????????????????????????
window.eval(code);

I'm using now:

function tryit(){
var a = 0;
}
var code = tryit.toString() + ";tryit();"; // <---------------- .toString is working
window.eval(code);

Flags: needinfo?(bfoss)

We removed toSource, because it is not standardized. For functions toSource was basically useless, it only sometimes added wrapping parenthesis.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
Regressed by: 1565170
You need to log in before you can comment on or make changes to this bug.