Closed Bug 1622054 Opened 4 months ago Closed 3 months ago

about:preferences searchbox font size in inconsistent with about:addons and about:logins

Categories

(Firefox :: Preferences, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 77
Tracking Status
firefox77 --- fixed

People

(Reporter: itiel_yn8, Assigned: itiel_yn8)

References

Details

Attachments

(2 files)

This was changed in bug 1432906 (apparently that was the intended behaviour), where the policies-container was set along with the searchbox to the (small-ish) size of 12.7px.

Not sure what is the correct spec for this, but either way I guess the searchbox should be consistent with other about: pages such as about:addons and about:logins, there the font size is set to 15px.

Moving this rule:
https://searchfox.org/mozilla-central/rev/278046367dab878316f60f0bd7f740cf73f3c447/browser/themes/shared/incontentprefs/preferences.inc.css#884
to here:
https://searchfox.org/mozilla-central/rev/278046367dab878316f60f0bd7f740cf73f3c447/browser/themes/shared/incontentprefs/preferences.inc.css#850
should fix it, while retaining the policies-container's font-size of 12.7px.

I'm confused, about:addons shows the same font size (12px) for me on macOS (courtesy of https://searchfox.org/mozilla-central/rev/3f8c67d7fd836d559491e3fe497bc739f707c1a6/toolkit/themes/osx/global/textbox.css#10 which seems to be mac-specific)? about:logins is indeed bigger.

Mark and Jared, can you clarify where the designs for the respective about:logins / about:addons content (which are both more recent than about:preferences, I think) has come from and what we should standardize on?

It's really not clear to me what the desired outcome was supposed to be here. :-\

Flags: needinfo?(mstriemer)
Flags: needinfo?(jaws)

Bug 1432906 made the font size smaller in preferences (85%) for the search input. about:logins and about:addons are more recent. Maybe Jacqueline can say which one we should use, but the desired outcome should be that we have one shared component without special styling changes for each page.

Flags: needinfo?(jaws) → needinfo?(jsavory)

Yes I agree that all three of these pages should have the same specs for their search boxes. Currently it looks like about:addons and about:preferences are using the same font size, so we should match that. It looks to me like its 13px, but in the bug you posted its 12.7px?

It looks like the search box itself is off between preferences and addons but lets stick with 32px high if we can.

ni? Shorlander just to double check that what I'm thinking is correct.

Flags: needinfo?(jsavory) → needinfo?(shorlander)
Attached image Screenshot

(In reply to Jacqueline Savory [:jsavory] UX from comment #3)

It looks to me like its 13px, but in the bug you posted its 12.7px?

The attached is from latest Nightly.

If we go with 15 it will be the same across all of the in-content header search fields (about:logins, about:preferences, about:addons) and the new tab page.

Flags: needinfo?(shorlander)
Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED
Flags: needinfo?(mstriemer)
Priority: -- → P3
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97da803dccb8
Make about:preferences searchbox font size consistent with searchboxes in about:logins and about:addons r=jaws
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
You need to log in before you can comment on or make changes to this bug.