Closed Bug 1622087 Opened 2 years ago Closed 2 years ago

Intermittent pup ValueError: Failed to convert value TERMINATED of type unicode for field status to type Status

Categories

(Remote Protocol :: Agent, defect, P5)

defect

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jgraham)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

James will have a look at this by tomorrow.

Flags: needinfo?(james)
Regressed by: 1607474

It's uncelar if this should be mapped to CRASH or ERROR, but
it probably doesn't matter much; it seems to be a fatal error
that terminates the rest of the run, but we don't get a stack.

I arbitarily chose CRASH.

Assignee: nobody → james
Status: NEW → ASSIGNED
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/b411a8d14392
Handle TERMINATED status in puppeteer tests, r=remote-protocol-reviewers,maja_zf

Note that there's still an underlying intermittent error here, but at least it should now be correctly reported.

Flags: needinfo?(james)

(In reply to James Graham [:jgraham] from comment #4)

Note that there's still an underlying intermittent error here, but at least it should now be correctly reported.

Correct, once landed we can trigger a new try build for Ubuntu 18.04 and see how the failure manifests.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
You need to log in before you can comment on or make changes to this bug.