Closed Bug 1622350 Opened 5 months ago Closed 5 months ago

Intermittent pointerlock/pointerevent_pointerlock_supercedes_capture.html.ini WPT FAIL with Fission

Categories

(Core :: DOM: Events, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Fission Milestone M6
Tracking Status
firefox76 --- fixed

People

(Reporter: cpeterson, Assigned: edgar)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The DOM Fission team is relying on feature teams to debug and fix Fission failures in their tests. If the failure looks like a bug in Fission's DOM or IPC changes, you can send the bug back to me.

We're hoping to enable Fission for a subset of Nightly users in early Q3, so we would like WPT tests to be green for Fission by end of Q2. Whether a particular test failure actually blocks shipping Fission is up to the discretion of the feature team. You all would know better than the DOM Fission which test failures are most important.

You can enable Fission when running WPT tests locally using mach wpt --enable-fission.

Hi Edgar, please help us to understand the importance and priority if you see fit, thanks.

Flags: needinfo?(echen)

It looks like a linux specific issue, but I could not reproduce locally.
Let's see if I could get some information from try push: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=a6eb96d50b600f989ade7b6f6fcf25b84b2b2b01

(In reply to Chris Peterson [:cpeterson] from comment #1)

You can enable Fission when running WPT tests locally using mach wpt --enable-fission.

BTW, It looks like mach for web-platform-tests dones't support --enable-fission as argument yet, I got

mach: error: unrecognized arguments for web-platform-tests: '--enable-fission'

I use --setpref fission.autostart=true to run wpt on fission mode instead.

(In reply to Edgar Chen [:edgar] from comment #3)

It looks like a linux specific issue, but I could not reproduce locally.
Let's see if I could get some information from try push: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=a6eb96d50b600f989ade7b6f6fcf25b84b2b2b01

https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=a6eb96d50b600f989ade7b6f6fcf25b84b2b2b01&searchStr=w-fis%2Cwpt5%2Copt%2CQuantumRender

I don't see intermittent error on try with 50+ retriggering, I think we could just enable it back.

Flags: needinfo?(echen)
Assignee: nobody → echen
Status: NEW → ASSIGNED
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad20ce9bdb8d
Enable pointerevent_pointerlock_supercedes_capture.html wpt back on linux-opt-fission; r=smaug
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
You need to log in before you can comment on or make changes to this bug.