Closed Bug 1622369 Opened 5 months ago Closed 4 months ago

Intermittent /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Performs removal in deeply nested iframes - assert_equals: expected "removed" but got "active"

Categories

(Core :: DOM: Animation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: boris)

References

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered], [wptsync upstream][stockwell unknown])

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=293080829&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/fBOF6Va9QAeOZf42j1TrGA/runs/0/artifacts/public/logs/live_backing.log


[task 2020-03-13T18:47:45.440Z] 18:47:45 INFO - TEST-START | /web-animations/timing-model/timelines/update-and-send-events-replacement.html
[task 2020-03-13T18:47:45.448Z] 18:47:45 INFO - Closing window 11
[task 2020-03-13T18:47:47.083Z] 18:47:47 INFO -
[task 2020-03-13T18:47:47.083Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Does NOT remove an animation after making a redundant change to another animation's current time
[task 2020-03-13T18:47:47.083Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Does NOT remove an animation after making a redundant change to its current time
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Does NOT remove an animation after making a redundant change to another animation's timeline
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Does NOT remove an animation after making a redundant change to its timeline
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Does NOT remove an animation after making a redundant change to another animation's effect's properties
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Does NOT remove an animation after making a redundant change to its effect's properties
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Updates ALL timelines before checking for replacement
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Dispatches remove events after finish events
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Fires remove event before requestAnimationFrame
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-PASS | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Queues all remove events before running them
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-UNEXPECTED-FAIL | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | Performs removal in deeply nested iframes - assert_equals: expected "removed" but got "active"
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - @http://web-platform.test:8000/web-animations/timing-model/timelines/update-and-send-events-replacement.html:1013:16
[task 2020-03-13T18:47:47.084Z] 18:47:47 INFO - TEST-INFO | expected TIMEOUT
[task 2020-03-13T18:47:47.441Z] 18:47:47 INFO - TEST-UNEXPECTED-OK | /web-animations/timing-model/timelines/update-and-send-events-replacement.html | expected TIMEOUT
[task 2020-03-13T18:47:47.441Z] 18:47:47 INFO - TEST-INFO expected TIMEOUT | took 1998ms
[task 2020-03-13T18:47:48.376Z] 18:47:48 INFO - Closing logging queue
[task 2020-03-13T18:47:48.376Z] 18:47:48 INFO - queue closed
[task 2020-03-13T18:47:48.392Z] 18:47:48 INFO - Setting up ssl
[task 2020-03-13T18:47:48.473Z] 18:47:48 INFO - certutil |
[task 2020-03-13T18:47:48.568Z] 18:47:48 INFO - certutil |
[task 2020-03-13T18:47:48.584Z] 18:47:48 INFO - certutil |
[task 2020-03-13T18:47:48.584Z] 18:47:48 INFO - Certificate Nickname Trust Attributes
[task 2020-03-13T18:47:48.584Z] 18:47:48 INFO - SSL,S/MIME,JAR/XPI
[task 2020-03-13T18:47:48.584Z] 18:47:48 INFO -
[task 2020-03-13T18:47:48.584Z] 18:47:48 INFO - web-platform-tests CT,,
[task 2020-03-13T18:47:48.584Z] 18:47:48 INFO -
[task 2020-03-13T18:47:51.480Z] 18:47:51 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2020-03-13T18:47:52.871Z] 18:47:52 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env8 R_LOG_DESTINATION=stderr --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 MOZ_HIDE_RESULTS_TABLE=1 --es env2 R_LOG_VERBOSE=1 --es env1 MOZ_WEBRENDER=0 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env6 MOZ_IN_AUTOMATION=1 --es env5 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env4 STYLO_THREADS=1 --ez use_multiprocess True --es env12 R_LOG_LEVEL=6 --es env11 MOZ_PROCESS_LOG=/tmp/tmpvix8Fspidlog --es env10 MOZ_CRASHREPORTER_NO_REPORT=1
[task 2020-03-13T18:47:54.684Z] 18:47:54 INFO - Starting runner

Flags: needinfo?(james)

Brian: is this something you hae time to investigate?

Flags: needinfo?(james) → needinfo?(brian)
Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]

Looks link the Chrome team updated that test to a "mechanism ... that is well behaved across browsers" ;)

https://hg.mozilla.org/mozilla-central/rev/1f66d281b8ce3b572f364f86102f3c132ec64c8d

I'm afraid I won't have time to look at this. Maybe Boris can?

(All my Gecko and spec work is volunteer-based and I currently have quite a pile of spec reviews and other Gecko work unfortunately.)

Flags: needinfo?(brian) → needinfo?(boris.chiou)

I keep the ni for now until I finish my current work (Bug 1621007). Will check this bug later.

Failures here started decreasing since the 18th of March.

In fact, as a result we now have unexpected passes too: bug 1625015

See Also: → 1625015

Just notice "Performs removal in deeply nested iframes" is easy to be reproduced on mac, becase of time-out or failed on my local build.

Flags: needinfo?(boris.chiou)
Assignee: nobody → boris.chiou

It's easy to get time out on mac if we await the promise inside
insertFrameAndAwaitLoad(), so move it out and let's see if there is
still timeout or intermittent.

Attachment #9136102 - Attachment description: Bug 1622369 - Return promise from the helper function and await it in promise_test. → Bug 1622369 - Await the async function to make sure any async steps inside the function will be blocked.
Pushed by bchiou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/254999e1d761
Await the async function to make sure any async steps inside the function will be blocked. r=birtles
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/22502 for changes under testing/web-platform/tests
Whiteboard: [retriggered][stockwell needswork:owner] → [retriggered][stockwell needswork:owner], [wptsync upstream]
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Upstream PR merged by stephenmcgruer
Duplicate of this bug: 1625015
You need to log in before you can comment on or make changes to this bug.