Closed Bug 1622420 Opened 5 months ago Closed 4 months ago

Can't get top-level WindowContext in the cross-origin iframe

Categories

(Core :: DOM: Content Processes, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Fission Milestone M5b
Tracking Status
firefox76 --- fixed

People

(Reporter: dimi, Assigned: peterv)

Details

Attachments

(3 files)

Steps to reproduce:

  1. Apply the attached patch which prints log when users interact with a document
  2. Go to https://dimidl.github.io/test/iframe/cross-origin-iframe.html
  3. mouse click the iframe
  4. debug message indicates there is no top-level window context

Notes.
top-level window context can be found in a same-origin iframe.
https://dimidl.github.io/test/iframe/same-origin-iframe.html

Assignee: nobody → dlee
Flags: needinfo?(afarre)
Assignee: dlee → nobody

Tracking for Fission M5b or early M6a to determine what's happening

Are we not sync'ing WindowContexts properly? Nika says this is unlikely to be a race because this code runs late after navigation has settled.

Peter will ping afarre tomorrow.

Fission Milestone: --- → M5
Priority: -- → P2
Whiteboard: [fission:m5b]
Fission Milestone: M5 → M5b
Whiteboard: [fission:m5b]
Assignee: nobody → peterv
Status: NEW → ASSIGNED
Pushed by pvanderbeken@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0e43ffd5251c
Set the current WindowContext for BrowsingContexts newly created over IPC. r=farre
https://hg.mozilla.org/integration/autoland/rev/1ad327ce20e3
Cleanup docshell/test/browser/browser_bug422543.js. r=farre
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Flags: needinfo?(afarre)
You need to log in before you can comment on or make changes to this bug.