Running external program - lack of decent error messages

RESOLVED FIXED in mozilla1.5beta

Status

Core Graveyard
File Handling
P3
normal
RESOLVED FIXED
16 years ago
2 years ago

People

(Reporter: Tim Connors, Assigned: Biesinger)

Tracking

(Depends on: 1 bug)

Trunk
mozilla1.5beta

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I am using 1.0.0 here, but I verified this for 1.1b as well....

When I open up a (e.g.) .ps document, and I have the viewer incorrectly set, I
get an error "blah could not be opened, because an unknown error occurred\nSorry
 about that".

Very appologetic and all, but couldn't it actually tell me what went wrong? Ie,
the file name of the program I entered does not exist? (or that it ran out of
memory, or that it could not fork, or whatever)

Steps to reproduce: Open up a .ps file, get promted with 
"open or save" dialog, go to advanced, tell it that the program to run is
"/filedoesnotexist", press ok, press ok.

You may think that I am being pathological, but here we have an nfs system, and
I have my defaults set up on alpha, but when I go to linux it mysteriously fails
all the time.....
QA Contact: sairuh → petersen
confirming... while the helper app dialog no longer lets you enter nonexistant
files, you can still do it in preferences, and you do get the mentioned error
message.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
-> me
Assignee: law → cbiesinger
Priority: -- → P3
Target Milestone: --- → mozilla1.6alpha
Created attachment 128184 [details] [diff] [review]
patch

give a nice error message if the helper app doesn't exist
Comment on attachment 128184 [details] [diff] [review]
patch

please ignore the removal of the #ifdef, I won't check that in
Attachment #128184 - Flags: review?(bzbarsky)
Status: NEW → ASSIGNED
Target Milestone: mozilla1.6alpha → mozilla1.5beta
Attachment #128184 - Flags: superreview?(darin)

Comment 6

15 years ago
Comment on attachment 128184 [details] [diff] [review]
patch

sr=darin
Attachment #128184 - Flags: superreview?(darin) → superreview+
Checking in uriloader/exthandler/nsExternalHelperAppService.cpp;
/cvsroot/mozilla/uriloader/exthandler/nsExternalHelperAppService.cpp,v  <-- 
nsExternalHelperAppService.cpp
new revision: 1.204; previous revision: 1.203
done
Checking in
embedding/components/webbrowserpersist/locale/en-US/nsWebBrowserPersist.properties;
/cvsroot/mozilla/embedding/components/webbrowserpersist/locale/en-US/nsWebBrowserPersist.properties,v
 <--  nsWebBrowserPersist.properties
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
*** Bug 154533 has been marked as a duplicate of this bug. ***
*** Bug 58667 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.