Closed
Bug 1622653
Opened 5 years ago
Closed 5 years ago
the 'empty' method should be used to check for emptiness instead of 'size'
Categories
(Developer Infrastructure :: Source Code Analysis, task)
Developer Infrastructure
Source Code Analysis
Tracking
(firefox76 fixed)
RESOLVED
FIXED
mozilla76
Tracking | Status | |
---|---|---|
firefox76 | --- | fixed |
People
(Reporter: Sylvestre, Assigned: siddhantagarwal99, Mentored)
References
(Blocks 1 open bug)
Details
(Keywords: good-first-bug, Whiteboard: [lang=C++])
Attachments
(1 file)
Filling as a good first bug to learn workflows.
MOZ_ASSERT(retAddrEntries().size() > 0);
should use .empty() instead
https://searchfox.org/mozilla-central/source/js/src/jit/BaselineJIT.cpp#717
As the change is trivial, it is just to learn how to contribute to Firefox.
Found by http://clang.llvm.org/extra/clang-tidy/checks/readability-container-size-empty.html
Tutorial to contribute:
https://firefox-source-docs.mozilla.org/tools/docs/contribute/how_to_contribute_firefox.html
Please don't ask for the bug to be assigned. It will be automatically assigned to the first patch.
Reporter | ||
Updated•5 years ago
|
Assignee | ||
Comment 1•5 years ago
|
||
Updated•5 years ago
|
Assignee: nobody → siddhantagarwal99
Status: NEW → ASSIGNED
Updated•5 years ago
|
Attachment #9134520 -
Attachment description: Bug 1622653 - used empty method r=Sylvestre → Bug 1622653 - BaselineJIT.cpp: Replace size()>0 by !empty() r=Sylvestre
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c462e17bc3fa
BaselineJIT.cpp: Replace size()>0 by !empty() r=sylvestre
Comment 3•5 years ago
|
||
bugherder |
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
status-firefox76:
--- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Updated•2 years ago
|
Product: Firefox Build System → Developer Infrastructure
You need to log in
before you can comment on or make changes to this bug.
Description
•