Closed Bug 1622820 Opened 5 months ago Closed 5 months ago

Evaluation Context selector button shouldn't stretch

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(Fission Milestone:M6, firefox76 fixed)

RESOLVED FIXED
Firefox 76
Fission Milestone M6
Tracking Status
firefox76 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission-m2-mvp)

Attachments

(2 files)

Attached image image.png

Steps to reproduce

  1. Open the browser toolbox with the context selector pref on
  2. Hit Shift + Enter multiple times to make the input taller

Expected results

Context selector button stays the same

Actual results

Context selector button grows (see screenshot)

Summary: Evlauation Context selector button shouldn't stretch → Evaluation Context selector button shouldn't stretch

Tracking Fission DevTools bugs for Fission Nightly (M6) milestone

Fission Milestone: --- → M6
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Priority: P2 → P1

The button was stretching vertically as the console input grew,
which looked weird.
This is fixed by aligning the item of the container differently
and adjusting padding and margins in order to properly aligh
the context selector and the editor switch button.
We take this as an opportunity to set a max width on the button,
since it could be quite large if the context name is long.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fb47d4641845
Fix evaluation context selector button UI. r=jlast.
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
QA Whiteboard: [qa-76b-p2]
You need to log in before you can comment on or make changes to this bug.